Adding a group as non admin causes error

Bug #1410570 reported by Robert Lyon on 2015-01-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Robert Lyon

Bug Description

Currently in master (15.04testing) a user can not create a group - they get this error:

[WAR] eb (lib/form/elements/wysiwyg.php:87) Invalid argument supplied for foreach()
Call stack (most recent first):

    log_message("Invalid argument supplied for foreach()", 8, true, true, "/home/robertl/htdocs/mahara-devel/mahara/htdocs/li...", 87) at /home/robertl/htdocs/mahara-devel/mahara/htdocs/lib/errors.php:441
    error(2, "Invalid argument supplied for foreach()", "/home/robertl/htdocs/mahara-devel/mahara/htdocs/li...", 87, array(size 2)) at /home/robertl/htdocs/mahara-devel/mahara/htdocs/lib/form/elements/wysiwyg.php:87
    pieform_element_wysiwyg_get_headdata(array(size 8)) at /home/robertl/htdocs/mahara-devel/mahara/htdocs/lib/pieforms/pieform.php:1732
    pieform_get_headdata() at /home/robertl/htdocs/mahara-devel/mahara/htdocs/lib/web.php:92
    smarty(array(size 0), array(size 0), array(size 0), array(size 1)) at /home/robertl/htdocs/mahara-devel/mahara/htdocs/lib/errors.php:576
    MaharaException->handle_exception() at /home/robertl/htdocs/mahara-devel/mahara/htdocs/lib/errors.php:467
    exception(object(AccessDeniedException)) at Unknown:0

This is due to a commit 36bc9f7d26076d74ebc6cd0672441eed8ed9cd2d calling group_update on group creation

Will fix up.

Reviewed: https://reviews.mahara.org/4168
Committed: http://gitorious.org/mahara/mahara/commit/6c62fef16da4656dcc7f3517309c5fbe3c0df00f
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit 6c62fef16da4656dcc7f3517309c5fbe3c0df00f
Author: Robert Lyon <email address hidden>
Date: Wed Jan 14 11:52:26 2015 +1300

Error in group creation for non admins (Bug #1410570)

Change-Id: Ic8759aa6541be740be88177dc4c16bf99000a77a
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2015-02-17
Changed in mahara:
status: Confirmed → Fix Committed
Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers