New Behat step: And I expand "text" node

Bug #1407854 reported by Jinelle Foley-Barnes on 2015-01-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Robert Lyon
15.04
Medium
Robert Lyon
15.10
Medium
Unassigned

Bug Description

Hi,

Could you please implement a step that says: And I expand "text" node. Moodle already uses this step.

I would be useful when you follow Portfolio -> Create page -> Edit content and then expanding the Media, Journals. General, Personal information and External tabs/nodes.

I have attached a piece of a test below that you can use to test the code change with.

Thanks,
Jinelle

Jinelle Foley-Barnes (jinelleb) wrote :
Changed in mahara:
status: New → Confirmed
importance: Undecided → Medium
Changed in mahara:
status: Confirmed → In Progress
Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4371

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4601

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4602

Robert Lyon (robertl-9) on 2015-04-14
Changed in mahara:
assignee: nobody → Robert Lyon (robertl-9)
Mahara Bot (dev-mahara) wrote :

Patch for "15.04_STABLE" branch: https://reviews.mahara.org/4620

Reviewed: https://reviews.mahara.org/4620
Committed: http://gitorious.org/mahara/mahara/commit/279d26d2eec6bf3a2e9b46ebbdb411b679e8b608
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.04_STABLE

commit 279d26d2eec6bf3a2e9b46ebbdb411b679e8b608
Author: Robert Lyon <email address hidden>
Date: Tue Apr 14 12:43:10 2015 +1200

The 'add block' dialogue now has 'Add' rather than 'Save' (Bug #1407854)

This is because the selenium gets confused by having two 'save'
buttons on the page, as the 'addblock' one gets hidden but still exists

Change-Id: Ieef1c583fa0f4ea5381ba931ab12f116556740cf
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
tags: added: has-behat
Robert Lyon (robertl-9) wrote :

still need to merge the behat step - only the change of 'Save' to 'Add' has been released to 15.04

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4601
Committed: http://gitorious.org/mahara/mahara/commit/8ef82ef553039218b7a4f66c8f105c7716393f01
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit 8ef82ef553039218b7a4f66c8f105c7716393f01
Author: Robert Lyon <email address hidden>
Date: Tue Apr 14 11:34:13 2015 +1200

Adding behat test: And I expand "text" node (Bug #1407854)

Change-Id: Iee5110eb9ffb9bcb1a6dbbcdfa1b8a43891db93e
Signed-off-by: Robert Lyon <email address hidden>

Reviewed: https://reviews.mahara.org/4602
Committed: http://gitorious.org/mahara/mahara/commit/ca2b15bb820f43b24776e499d2c9073d7baa7a04
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit ca2b15bb820f43b24776e499d2c9073d7baa7a04
Author: Robert Lyon <email address hidden>
Date: Tue Apr 14 12:43:10 2015 +1200

The 'add block' dialogue now has 'Add' rather than 'Save' (Bug #1407854)

This is because the selenium gets confused by having two 'save'
buttons on the page, as the 'addblock' one gets hidden but still exists

Change-Id: Ieef1c583fa0f4ea5381ba931ab12f116556740cf
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4371
Committed: http://gitorious.org/mahara/mahara/commit/ab8c66b935ad298fcef2f5ba2537fb8f207c82ed
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit ab8c66b935ad298fcef2f5ba2537fb8f207c82ed
Author: Jinelle Foley-Barnes <email address hidden>
Date: Mon Mar 9 15:25:48 2015 +1300

Behat Test: Adding a note block (Bug 1424512)

This is a behat test for bug (Bug 1424512) so it is dependent of that fix.
Also depended on the General node being able to expand (Bug 1407854)

Change-Id: I07112335965e44d9e80370bc0b3856d1cf38184d

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4713

Reviewed: https://reviews.mahara.org/4699
Committed: http://gitorious.org/mahara/mahara/commit/38af06e62a72b51c0db5012f3114d54ddf6ef559
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.04_STABLE

commit 38af06e62a72b51c0db5012f3114d54ddf6ef559
Author: Robert Lyon <email address hidden>
Date: Tue Apr 14 11:34:13 2015 +1200

Adding behat test: And I expand "text" node (Bug #1407854)

Change-Id: Iee5110eb9ffb9bcb1a6dbbcdfa1b8a43891db93e
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4701
Committed: http://gitorious.org/mahara/mahara/commit/1feb09e2fde2cde9d1faad2cb3bc2ec483d9fc46
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.04_STABLE

commit 1feb09e2fde2cde9d1faad2cb3bc2ec483d9fc46
Author: Jinelle Foley-Barnes <email address hidden>
Date: Mon Mar 9 15:25:48 2015 +1300

Behat Test: Adding a note block (Bug 1424512)

This is a behat test for bug (Bug 1424512) so it is dependent of that fix.
Also depended on the General node being able to expand (Bug 1407854)

Change-Id: I07112335965e44d9e80370bc0b3856d1cf38184d

Hi Rob,

Screen shot of the pop up block.

-Jinelle

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4713
Committed: http://gitorious.org/mahara/mahara/commit/b454a9ae587d5742fe6ab6503a3898512c7a5d9a
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit b454a9ae587d5742fe6ab6503a3898512c7a5d9a
Author: Robert Lyon <email address hidden>
Date: Wed Apr 29 12:27:16 2015 +1200

Altering 'cancel' on addblock to 'undo' to avoid clash

Bug 1407854

Change-Id: I659f2daf5032dbdea495596690162b52795044a9
Signed-off-by: Robert Lyon <email address hidden>

Reviewed: https://reviews.mahara.org/4740
Committed: http://gitorious.org/mahara/mahara/commit/02d86183c78ff5b3c9998239760c1b1dd9c7ec83
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.04_STABLE

commit 02d86183c78ff5b3c9998239760c1b1dd9c7ec83
Author: Robert Lyon <email address hidden>
Date: Wed Apr 29 12:27:16 2015 +1200

Altering 'cancel' on addblock to 'undo' to avoid clash

Bug 1407854

Change-Id: I659f2daf5032dbdea495596690162b52795044a9
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2016-11-06
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers