Behat cant click links when the duplicate ones are hidden.

Bug #1407848 reported by Jinelle Foley-Barnes on 2015-01-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Son Nguyen
15.04
Medium
Unassigned
15.10
Medium
Son Nguyen

Bug Description

Hi Sonn,

When you log in as an Admin follow Administration and on the Admin home/Overview page all the green links under the blue headings cannot be clicked. There are hidden duplicate links stopping Behat from being able to click these.

I have attached a part of a test that you can use to test if your code has worked or not. The part it is failing on is "Site options".

Thanks
Jinelle

Jinelle Foley-Barnes (jinelleb) wrote :
Changed in mahara:
assignee: nobody → Son Nguyen (ngson2000)
importance: Undecided → Medium
status: New → Confirmed
Jinelle Foley-Barnes (jinelleb) wrote :

Hi,

I've encountered this error again. When I try navigate to a page within a group. The "Pages" tab has a hidden version of it's self. We may also have to be careful here not to interfere with the accessibility.

Also I cant fill in the Message text box for placing feedback on someones group page.

I have pushed a broken test to Gerrit with these specific errors indicated with ** and when we find a solution we can apply the fix to the test.

Thanks so much,
Jinelle

Jinelle Foley-Barnes (jinelleb) wrote :

Another instance of this is:

When Behat tries creating a new forum inside a group, and tries typing in the description. it cant type in the text box because there is a hidden text box that it is seeing first.

This also happens when creating a new topic when I am trying to type in the message text box of a new topic.

I have pushed a test to Gerrit with this error and I have ** the areas that this is happening so it is easily identifiable.

Thanks heaps,
Jinelle

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/4363

Jinelle Foley-Barnes (jinelleb) wrote :

Another instance of this is :

Behat tries filling in the Entry text box for Journal.
Follow Content -> Journal -> New entry -> then try get it to fill in the entry it cant.

I'll attached a patch in Gerrit where this is happening.

Thank you,
Jinelle

Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
milestone: 15.04.0 → 15.04.1
Robert Lyon (robertl-9) wrote :

The problem with making a journal entry is due to the <textarea> field being hidden by tinymce

A bug and fix for this is listed here -> https://bugs.launchpad.net/mahara/+bug/1447449

Robert Lyon (robertl-9) wrote :

This has been fixed with: And I choose "Pages" in "Configure site"

Robert Lyon (robertl-9) on 2016-11-06
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments