PDFs not displaying in IE

Bug #1400595 reported by Anita Bridgman on 2014-12-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Son Nguyen
1.10
High
Unassigned

Bug Description

When a PDF block is added to a page, the PDF page doesn't display in IE. In IE, all that is displayed is a grey box. The PDF menu items are displayed but the actual document isn't visible. It works correctly in Chrome. I've tested this in the Mahara demo site and the problem existed there as well.

I've attached screenshots.

Version info:
Mahara 1.10.1
IE: 9
Chrome: 39

Anita Bridgman (anita-bridgman) wrote :
Aaron Wells (u-aaronw) on 2014-12-11
Changed in mahara:
status: New → Triaged
importance: Undecided → High
Aaron Wells (u-aaronw) wrote :

Thanks for the bug report!

I tried it out and got the same result. The PDF displays in IE10 and non-IE browsers, but it does not display in IE9.

Changed in mahara:
status: Triaged → Confirmed

Could it be that pdf.js (I think that's the library we use) does not work in IE9 because it is too old for it?

Changed in mahara:
milestone: none → 15.04.0
Son Nguyen (ngson2000) wrote :

The library pdf.js supports for IE9 but the performance may be slow.
https://github.com/mozilla/pdf.js/wiki/Frequently-Asked-Questions#what-browsers-are-supported

Son Nguyen (ngson2000) wrote :

PDF block works in FF but not in my Chrome (32.0.1700.102) any more

Son Nguyen (ngson2000) wrote :

Sorry about the wrong above comment
It works on my Firefox and Google Chrome (Version 39.0.2171.95 (64-bit))
but NOT on Chromium (Version 32.0.1700.102)

Reviewed: https://reviews.mahara.org/4370
Committed: http://gitorious.org/mahara/mahara/commit/abfe9bec5f87b3a8ac8cedfbdf86735e9e2304eb
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit abfe9bec5f87b3a8ac8cedfbdf86735e9e2304eb
Author: Son Nguyen <email address hidden>
Date: Mon Mar 9 14:31:16 2015 +1300

Fix the js error in IE9 when displaying PDF. Bug 1400595

Change-Id: Iaa1ef43f30615c253df28c70d20db415779146b8
Signed-off-by: Son Nguyen <email address hidden>

Son Nguyen (ngson2000) on 2015-03-11
Changed in mahara:
status: Confirmed → Fix Committed
assignee: nobody → Son Nguyen (ngson2000)
Son Nguyen (ngson2000) wrote :

The patch https://reviews.mahara.org/4370 worked after upgrade pdfjs lib.
I'll check if it works for older pdfjs lib

Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released

Reviewed: https://reviews.mahara.org/4799
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/3080ce5e653fac90ca3b3f10b7bf3f022959b7da
Submitter: Aaron Wells (<email address hidden>)
Branch: 1.10_STABLE

commit 3080ce5e653fac90ca3b3f10b7bf3f022959b7da
Author: Son Nguyen <email address hidden>
Date: Mon Mar 9 14:31:16 2015 +1300

Fix the js error in IE9 when displaying PDF. Bug 1400595

Change-Id: Iaa1ef43f30615c253df28c70d20db415779146b8
Signed-off-by: Son Nguyen <email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers