Unable to load page after submitting a comment on a view

Bug #1400514 reported by Robert Lyon on 2014-12-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Robert Lyon

Bug Description

Affects - latest master - due to adodb upgrade

Get error:

[WAR] 72 (lib/errors.php:745) Invalid values parameter sent to get_recordset_sql.
Call stack (most recent first):

    log_message("Invalid values parameter sent to get_recordset_sql...", 8, true, true) at /home/robertl/htdocs/mahara-devel/mahara/htdocs/lib/errors.php:95
    log_warn("Invalid values parameter sent to get_recordset_sql...") at /home/robertl/htdocs/mahara-devel/mahara/htdocs/lib/errors.php:745
    SQLException->__construct("Invalid values parameter sent to get_recordset_sql...") at /home/robertl/htdocs/mahara-devel/mahara/htdocs/lib/dml.php:457
    get_recordset_sql(" SELECT aa.artefact, a...", "", "", "") at /home/robertl/htdocs/mahara-devel/mahara/htdocs/lib/dml.php:660
    get_records_sql_array(" SELECT aa.artefact, a...", "") at /home/robertl/htdocs/mahara-devel/mahara/htdocs/artefact/lib.php:1120

The problem is now that adodb is upgraded it is more strict on what it accepts as $values

Needs to be empty array() and not empty string

Reviewed: https://reviews.mahara.org/4066
Committed: http://gitorious.org/mahara/mahara/commit/ee4a55fd5099dcbf269d5d263353f53b39216053
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit ee4a55fd5099dcbf269d5d263353f53b39216053
Author: Robert Lyon <email address hidden>
Date: Tue Dec 9 11:16:58 2014 +1300

Making sure empty $values parameter is sent as array() (Bug #1400514)

To test: checkout master - try and add a comment to a page on page
reload you should get an error

With patch - adding/viewing comments should work again

Change-Id: Ic32a5f7daf273385b745c57622abac369e388197
Signed-off-by: Robert Lyon <email address hidden>

Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers