Error display on the admin menus (tabs) of theme 'primaryschool'

Bug #1397562 reported by Juan Menéndez on 2014-11-29
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Robert Lyon
1.10
Medium
Robert Lyon

Bug Description

Version of Mahara: 1.10.1
Database: MySQL
Platform: any
Browser: any

Steps to replicate:

1. Select theme 'primaryschool' in the site settings
2. Click the menu (tab) 'Administration'
Error display between menu (tab) 'Groups' and menu (tab) 'Institutions'

Sorry for my limited english!

Hello Juan,

Thank you for your report.

Can you please attach a screenshot of what the site looks like with the error that you get? I cannot replicate the issue on 2 of my instances (though not on MySQL).

Also: Did you make any theme changes to the primaryschool theme? Is your site on http or https?

Thank you
Kristina

Changed in mahara:
status: New → Incomplete
Juan Menéndez (juan-menendez) wrote :

Hello Kristina,

Now, I attached two screenshots where you can see the error.
The error is marked in the screenshot by a red arrow.

Also: No changes to the primaryschool theme and my site is on 'http'

Juan Menéndez (juan-menendez) wrote :

This is de second screenshot

Juan Menéndez (juan-menendez) wrote :

Steps to replicate the error of screenshot 1 (error1-display-theme-primaryschool.png):

1. Select theme 'primaryschool' in the site settings
2. Click on the menu (tab) 'Administration'

Steps to replicate the error of screenshot 2 (error2-display-theme-primaryschool.png):

1. Select theme 'primaryschool' in the site settings
2. Click on the menu (tab) 'Administration - Groups'

Aaron Wells (u-aaronw) wrote :

I am able to replicate the problem, with Mahara 1.10.1 on Postgres.

This problem only seems to occur with the tabs in the Administration section, not the tabs that normal users see. I've updated the bug title to reflect that.

Changed in mahara:
milestone: none → 1.10.2
status: Incomplete → Confirmed
importance: Undecided → Medium
summary: - Error display on the menus (tabs) of theme 'primaryschool'
+ Error display on the admin menus (tabs) of theme 'primaryschool'
tags: added: primaryschool theming
Aaron Wells (u-aaronw) wrote :

Using git bisect, I traced the problem to this patch:

https://reviews.mahara.org/#/c/3398/

Accessible hidden text added to group admin nav link (Bug #1265097)

So that 'Groups' reads out as either 'Administer groups' for those
screenreaders that respect aria-hidden or 'Groups (Administer groups)'
in admin section when dropdown navigation is off to differentiate it
from the 'Groups' in main section.

When the dropdown is on the submenu list is read out so easily
indicates where one is already.

Change-Id: Ia70d742e8940fa6ec35957c97588a2ad719a62df
Signed-off-by: Robert Lyon <email address hidden>

For testing this: Make sure that you do not have the drop-down menu option for the main navigation activated in the site settings. It is only visible when you have tabs.

Aaron Wells (u-aaronw) wrote :

This problem is not present in 15.04.0. Presumably it was fixed as part of the 15.04 style changes.

Changed in mahara:
milestone: 15.04.1 → none
no longer affects: mahara/15.04
Changed in mahara:
status: Confirmed → Fix Released
Aaron Wells (u-aaronw) wrote :

Juan reported in Bug 1466830, that this problem is still present in Mahara 15.04.1

Changed in mahara:
status: Fix Released → Triaged
milestone: none → 15.04.2
Aaron Wells (u-aaronw) wrote :

To replicate:

1. Log in as admin
2. Change theme to "Primary"
3. Navigate to Administration -> Groups

When you are actually *on* a page under the Administration -> Groups tab, you will see the "Groups" tab has an ugly gray split down the middle.

Aaron Wells (u-aaronw) on 2015-07-10
Changed in mahara:
milestone: 15.04.2 → 15.04.3
Juan Menéndez (juan-menendez) wrote :

This error is also displayed in version 1.10.5

Robert Lyon (robertl-9) on 2015-07-29
Changed in mahara:
status: Triaged → In Progress
assignee: nobody → Robert Lyon (robertl-9)
Mahara Bot (dev-mahara) wrote :

Patch for "1.10_STABLE" branch: https://reviews.mahara.org/5021

Robert Lyon (robertl-9) wrote :

As the fix is quite small I've pushed a patch to fix this in 1.10 and 15.04

In v1.10 the problem existed whether one had clicked on 'Groups' or not

In v.15.04 the problem only existed when 'Groups' was selected

Reviewed: https://reviews.mahara.org/5020
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/6084552c4e1f9e6297a8d243bdcb95abaffe1235
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.04_STABLE

commit 6084552c4e1f9e6297a8d243bdcb95abaffe1235
Author: Robert Lyon <email address hidden>
Date: Thu Jul 30 09:25:14 2015 +1200

Bug 1397562: Primary school theme admin group tab style fix

The group tab in admin section when dropdown navigation was off had a
split in the button when selected due to the 2nd span in markup for that
tab.

The css fix ignores the 2nd span.

Change-Id: I28fd63d929dbfc9f4d7c27bfb8c2d0b46ff00efc
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/5021
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/c6ccf0e64f4603751ee060b41ca3f4d3ba535a38
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.10_STABLE

commit c6ccf0e64f4603751ee060b41ca3f4d3ba535a38
Author: Robert Lyon <email address hidden>
Date: Thu Jul 30 09:25:14 2015 +1200

Bug 1397562: Primary school theme admin group tab style fix

The group tab in admin section when dropdown navigation was off had a
split in the button when selected due to the 2nd span in markup for that
tab.

The css fix ignores the 2nd span.

Change-Id: I28fd63d929dbfc9f4d7c27bfb8c2d0b46ff00efc
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2015-07-30
Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2015-08-19
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers