Error when layout options are changed in Firefox

Bug #1396837 reported by Yuliya Bozhko on 2014-11-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Low
Yuliya Bozhko

Bug Description

An error occurs when you try to change row options in custom layouts in FF:

Failed to get a recordset: postgres7 error: [-1: ERROR: invalid input syntax for integer: "null"] in EXECUTE("SELECT widths FROM "mhr_view_layout_columns" WHERE "id" = ? "), referer: http://192.168.12.118/mahara/view/layout.php?id=14

Command was: SELECT widths FROM "mhr_view_layout_columns" WHERE "id" = ? and values was (null), referer: http://192.168.12.118/mahara/view/layout.php?id=14

Call stack (most recent first):, referer: http://192.168.12.118/mahara/view/layout.php?id=14

 * log_message("Failed to get a recordset: postgres7 error: [-1: E...", 8, true, true) at /home/yuliya/repos/mahara/htdocs/lib/errors.php:95, referer: http://192.168.12.118/mahara/view/layout.php?id=14

  * log_warn("Failed to get a recordset: postgres7 error: [-1: E...") at /home/yuliya/repos/mahara/htdocs/lib/errors.php:745, referer: http://192.168.12.118/mahara/view/layout.php?id=14

 * SQLException->__construct("Failed to get a recordset: postgres7 error: [-1: E...") at /home/yuliya/repos/mahara/htdocs/lib/dml.php:470, referer: http://192.168.12.118/mahara/view/layout.php?id=14

 * get_recordset_sql("SELECT widths FROM "mhr_view_layout_columns" WHER...", array(size 1)) at /home/yuliya/repos/mahara/htdocs/lib/dml.php:781, referer: http://192.168.12.118/mahara/view/layout.php?id=14

  * get_field_sql("SELECT widths FROM "mhr_view_layout_columns" WHER...", array(size 1)) at /home/yuliya/repos/mahara/htdocs/lib/dml.php:769, referer: http://192.168.12.118/mahara/view/layout.php?id=14

 * get_field("view_layout_columns", "widths", "id", "null") at /home/yuliya/repos/mahara/htdocs/lib/view.php:1051, referer: http://192.168.12.118/mahara/view/layout.php?id=14

 * View->updatecustomlayoutpreview(array(size 3)) at /home/yuliya/repos/mahara/htdocs/lib/view.php:1819, referer: http://192.168.12.118/mahara/view/layout.php?id=14

 * View->process_changes() at /home/yuliya/repos/mahara/htdocs/view/blocks.json.php:30, referer: http://192.168.12.118/mahara/view/layout.php?id=14

To reproduce:

1. In FF, go to layout page, to editing custom layouts.
2. Default one is row 1 with 3 columns.
3. Select 1 column per row, then select 2 columns per row, then select 1 column again.
4. See the above error at the top of the page.

Chrome seems to be working fine. Didn't try IE.

Changed in mahara:
status: New → In Progress
Changed in mahara:
milestone: none → 15.04.0

Reviewed: https://reviews.mahara.org/4040
Committed: http://gitorious.org/mahara/mahara/commit/b5d0274fedcd1f0bde57ee0a8abd2c398c2465f6
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit b5d0274fedcd1f0bde57ee0a8abd2c398c2465f6
Author: Yuliya Bozhko <email address hidden>
Date: Thu Nov 27 14:16:53 2014 +1300

Fix error on page custom layout options change in Firefox (Bug #1396837)

Change-Id: Ie6c593d72dd869db59b7aba26c428ea74f14cb7b
Signed-off-by: Yuliya Bozhko <email address hidden>

Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers