Overflowing table in the Admin Notifications page

Bug #1396364 reported by David Ligne on 2014-11-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Low
Evonne Cheung
1.10
Low
Unassigned
1.8
Low
Unassigned
1.9
Low
Unassigned
15.04
Low
Evonne Cheung

Bug Description

Tested on versions 1.10 and 1.09, with Firefox, Chrome, IE.

- Choose a language other than english (I tested it in french).
- Go to Administration / Institutions / Admin Notifications
- The table is overflowing off the page.

David Ligne (david-ligne) wrote :
Aaron Wells (u-aaronw) on 2015-03-03
Changed in mahara:
status: New → Confirmed
importance: Undecided → Low
milestone: none → 15.04.0
tags: added: admin notifications theming translations
tags: added: bite-sized
Aaron Wells (u-aaronw) wrote :

Hi David,

Thanks for the bug report! I can confirm that the same thing happens in Mahara 15.04 as well.

The problem is more noticeable if you're using the French translation, because the translations are longer than the English versions. But the same thing does happen in English as well, if you set the page narrowly enough.

Things we could do to fix this:

1. Currently it appears the column headers are set to disallow word wrap. Allowing word wrap would help.

2. Decreasing the font size of the column headers might work as well.

3. (Most radically) use a JS library or HTML5 to rotate the column headers so that the text runs vertically or diagonally up from the table, instead of horizontally.

Since the page is still useable, and it's only an admin interface, I'm setting the bug to "low" priority.

Cheers,
Aaron

I think word wrap is a CSS fix. So we can look at that as part of the UI freeze for 15.04.

Evonne made a patch for item 1, the word wrap. It can be pulled into the review system.

Reviewed: https://reviews.mahara.org/4367
Committed: http://gitorious.org/mahara/mahara/commit/56598380da8379647e6b447392dd30843acc2ba3
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 56598380da8379647e6b447392dd30843acc2ba3
Author: Evonne Cheung <email address hidden>
Date: Mon Mar 9 11:12:44 2015 +1300

Overflowing table headers on Admin Notifications page

Bug 1396364

Change-Id: Ie76f2e0852e23418a368758726616850f6e19b3b

Robert Lyon (robertl-9) on 2015-03-08
no longer affects: mahara/15.10
Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers