Visits counter not showing with "small headers"

Bug #1395627 reported by Emilie Lenel on 2014-11-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Robert Lyon
1.10
High
Robert Lyon
15.04
High
Robert Lyon

Bug Description

Hello
I'd like to submit a new feature request (asked by our users)
Would it be possible to provide to ePortfolio owners, a statistics view with hit counter with the number of visits on their shared pages ?
Thanks
BR
Emilie Lenel

Hi Emilie,

There is already a hit counter for every page. However, it looks like (testing it on 1.10), that it is not always displayed in all themes.

I couldn't see it in the default theme, but when I switched to Aqua, it displayed correctly. Switching back to Default, I could see the hit counter. It seems that the footer might be problematic.

Cheers
Kristina

Changed in mahara:
status: New → Confirmed
importance: Undecided → Medium
summary: - Provides users statistics on their shared pages
+ Display number of visits on a page
Changed in mahara:
importance: Medium → High
tags: added: regression

I could not see the page visits on demo.mahara.org but can see them without problems (after switching themes) on my local 1.10 installation. And they worked out of the box on my local 1.9 instance.

It would be good to see if others have this problem as well and whether it is theme specific.

Dominique-Alain JAN (dajan) wrote :

I am using the theme Configurable and I don't get any stats on the number of hits for the shared pages.

Robert Lyon (robertl-9) wrote :

Ok, the stats show only if these criteria are met:

1) The cron_site_data_daily has to have run since the page was created. So if you create a page, share it, and then visit it with other users the stats for this will only be available after the cron_site_data_daily has generated them for the view.

2) If point 1 is met, then the page will only show the stats if 'Small page headers' is turned off.

Point 1 seems fine and normal practice so I'd leave that the same.

Point 2 should be changed as the stats are shown at the base of the page so shouldn't affect display/layout much anyway. I'll adjust the system to allow the displaying of the stats for both small and large page headers.

Reviewed: https://reviews.mahara.org/4095
Committed: http://gitorious.org/mahara/mahara/commit/23d7f8808787f8fd61ed375acd2a5775ee760142
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 23d7f8808787f8fd61ed375acd2a5775ee760142
Author: Robert Lyon <email address hidden>
Date: Tue Dec 16 10:01:11 2014 +1300

Allowing visit stats to display on microheaders view (Bug #1395627)

Also pluralising the lang string

Change-Id: Ib98b5d4809d4c8a7dca30ccc0f735e9bdcb078de
Signed-off-by: Robert Lyon <email address hidden>

Aaron Wells (u-aaronw) on 2014-12-16
summary: - Display number of visits on a page
+ Visits counter not showing with "small headers"

Reviewed: https://reviews.mahara.org/4129
Committed: http://gitorious.org/mahara/mahara/commit/0437c7492af6f20804688b4c68a11ae2d0ca9cff
Submitter: Son Nguyen (<email address hidden>)
Branch: 1.10_STABLE

commit 0437c7492af6f20804688b4c68a11ae2d0ca9cff
Author: Robert Lyon <email address hidden>
Date: Tue Dec 16 10:01:11 2014 +1300

Allowing visit stats to display on microheaders view (Bug #1395627)

Also pluralising the lang string

Change-Id: Ib98b5d4809d4c8a7dca30ccc0f735e9bdcb078de
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers