Images not displayed - blog post by tag

Bug #1392700 reported by Stéphane Lavoie on 2014-11-14
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mahara
Medium
Son Nguyen
1.10
Medium
Son Nguyen
1.8
Medium
Unassigned
1.9
Medium
Unassigned
15.04
Medium
Son Nguyen

Bug Description

Reported by a user who couldn't see anonymously images on a new public view.

I made a simulation and the problem is related to the block blog post by tag. You can see the exact same blog post on http://mahara.ticfga.ca/user/smlavoie/tests-pour-images . ON the left side, each post is displayed using ONE post, on the right, post by tag.

The problem seems to be related to the absence of the view parameter in the display of images.

Mahara 1.9.1 on linux with MySQL, tested on IE, FF and Chrome (on Win8)

Confirmed also for 1.10 on demo.mahara.org and for master. Most likely also a problem for 1.8.

Changed in mahara:
status: New → Confirmed
importance: Undecided → High
milestone: none → 15.04.0
Aaron Wells (u-aaronw) wrote :

I tried this with all four blog blocks: "Journal entry", "Journal", "Recent journal entries", and "Tagged journal entries". The problem is present only with the "Tagged journal entries" blocks. (The "Recent journal entries" block doesn't show blog entry contents.)

To replicate:

1. Create a blog entry.
2. Attach a file to the blog entry.
3. In TinyMCE, use the "image" button to insert the attached file into the blog entry text.
4. Put at least one tag on the blog entry.
5. Create a page.
6. In the page, put a "Tagged journal entries" block
7. Make the block use the tag you entered in step 4
8. Tick the box "Show journal entries in full"
9. Save the block
10. Make the page accessible to the public
11. View the page while logged out

Expected result: You should see the image in the blog entry.

Actual result: You will not see the image in the blog entry. (You may see the "Broken image" icon, depending on your browser.)

I replicated the problem in 1.8 as well.

Aaron Wells (u-aaronw) wrote :

Implementation-wise, the problem is that the "Journal" and "Journal entry" blocks do $blogpost->render_self() to display each entry, while the "Tagged journal entries" block instead has logic in the template file that prints the raw content of the blog post.

Son Nguyen (ngson2000) wrote :

I found more issues related to the tagged journal entry block

1. Attached files section is not displayed even for the owner
2. For the page accessible to public, images linked in the entry description are not shown.

Reviewed: https://reviews.mahara.org/4130
Committed: http://gitorious.org/mahara/mahara/commit/4b7768ff45079e376cdb42e143cb9cd8af5776f6
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 4b7768ff45079e376cdb42e143cb9cd8af5776f6
Author: Son Nguyen <email address hidden>
Date: Fri Jan 9 08:12:16 2015 +1300

Refactor the tagged blogpost blocktype. Bug 1392700

- Use render_self() in full detail option
- Remove calls of $artefact->get() in template file

Change-Id: I6be321adfda07c7f3e7cb3ac4026894b081e131f
Signed-off-by: Son Nguyen <email address hidden>

Reviewed: https://reviews.mahara.org/4133
Committed: http://gitorious.org/mahara/mahara/commit/b8cf6df1692c2076054ddd8602a686ae6afee025
Submitter: Aaron Wells (<email address hidden>)
Branch: 1.10_STABLE

commit b8cf6df1692c2076054ddd8602a686ae6afee025
Author: Son Nguyen <email address hidden>
Date: Fri Jan 9 08:12:16 2015 +1300

Refactor the tagged blogpost blocktype. Bug 1392700

- Use render_self() in full detail option
- Remove calls of $artefact->get() in template file

Change-Id: I6be321adfda07c7f3e7cb3ac4026894b081e131f
Signed-off-by: Son Nguyen <email address hidden>

Mahara Bot (dev-mahara) wrote :

Patch for "1.8_STABLE" branch: https://reviews.mahara.org/4147

Reviewed: https://reviews.mahara.org/4147
Committed: http://gitorious.org/mahara/mahara/commit/bae3f3fcd248fdccfbe0176b45a3f1c07f245a4e
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.8_STABLE

commit bae3f3fcd248fdccfbe0176b45a3f1c07f245a4e
Author: Son Nguyen <email address hidden>
Date: Fri Jan 9 08:12:16 2015 +1300

Refactor the tagged blogpost blocktype. Bug 1392700

- Use render_self() in full detail option
- Remove calls of $artefact->get() in template file

Change-Id: I6be321adfda07c7f3e7cb3ac4026894b081e131f
Signed-off-by: Son Nguyen <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/4146
Committed: http://gitorious.org/mahara/mahara/commit/0b68ff430f265aabdb71cde5f983fa3d0f76e99e
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.9_STABLE

commit 0b68ff430f265aabdb71cde5f983fa3d0f76e99e
Author: Son Nguyen <email address hidden>
Date: Fri Jan 9 08:12:16 2015 +1300

Refactor the tagged blogpost blocktype. Bug 1392700

- Use render_self() in full detail option
- Remove calls of $artefact->get() in template file

Change-Id: I6be321adfda07c7f3e7cb3ac4026894b081e131f
Signed-off-by: Son Nguyen <email address hidden>

Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers