Duplicate text and Image blocks

Bug #1389450 reported by Jinelle Foley-Barnes on 2014-11-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Aaron Wells

Bug Description

Hi,

An idea for the next release would be to remove the duplicate text and image blocks from the Portfolio->Edit content block palette.

Currently there is a Text and Image short cut at the top of the block pallete which is fantastic. However Text is duplicated in the expandable General block, and Image is duplicated in the expandable Media block.

Thanks,
Jinelle

Aaron Wells (u-aaronw) on 2014-11-07
tags: added: usability
Changed in mahara:
status: New → Confirmed
assignee: nobody → Aaron Wells (u-aaronw)
tags: added: pagebuilder
Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/3942

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/3943

Aaron Wells (u-aaronw) on 2014-11-07
Changed in mahara:
status: Confirmed → In Progress
Aaron Wells (u-aaronw) wrote :

After a little thought, I decided to reassign the patches 3943 and 3944 to other bugs. So just 3942 counts for this bug now. :)

Aaron Wells (u-aaronw) wrote :

https://reviews.mahara.org/3942 : Removes the blocktype categories from the "text" and "image" blocks, so that they only show up in their position hard-coded at the top of the block picker.

https://reviews.mahara.org/3943 : Bug 1390339: Adds an API for determining which blocktypes show up at the top of the block picker, instead of just hard-coding them in.

https://reviews.mahara.org/3944 : Bug 1236102: Adds an API to determine what order the blocktypes are sorted by, within a blocktype category.

So strictly speaking, we can achieve this bug with just patch 3942. We can remove the hard-coded blocks with patch 3943. And then we need patch 3944 to put the "text" block before the "image" block again.

Reviewed: https://reviews.mahara.org/3942
Committed: http://gitorious.org/mahara/mahara/commit/cdfba205e2bbaf46fd78345113f193e7c46da34a
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit cdfba205e2bbaf46fd78345113f193e7c46da34a
Author: Aaron Wells <email address hidden>
Date: Fri Nov 7 19:51:20 2014 +1300

Remove "text" and "image" from blocktype categories

Bug 1389450
... since they're also present at the top of the block picker.

Change-Id: I758be5c4fd8da81a23bbcf1feecbe89c23b91f9a

Changed in mahara:
status: In Progress → Fix Committed
tags: added: usermanualupdate
Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers