Alphabetize notification settings

Bug #1388682 reported by Kristina Hoeppner on 2014-11-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Amelia Cordwell

Bug Description

Mahara 1.10+

There are now all notification settings listed under "Notification settings" on /admin/site/options.php

These options should be alphabetized as there is no apparent order to the current listing.

There are two options:

1. Alphabetize the entire list.
2. Alphabetize the list grouped into two: Users and administrators

Alphabetize entire list
=========================
Contact us
Feedback
Group message
Institution message
Message from other users
New forum post
New page access
Objectionable content
Objectionable content in forum
Repeat virus upload
System message
Virus flag release
Watchlist

Alphebetize the list grouped into two
====================================

User notifications (heading)
----------------------------
Feedback
Group message
Institution message
Message from other users
New forum post
New page access
Objectionable content in forum
System message
Watchlist

Site administrator-only notifications
---------------------------------------------------
Contact us
Objectionable content (Help icon: Institution administrators also receive these notifications)
Repeat virus upload
Virus flag release

==================================

The notifications will also need to be alphabetized in the same fashion on /account/activity/preferences/index.php
and appropriate admin notifications only be shown to those that are allowed to see them (see bug #946724)

Discussed with Hugh, and it would be better to say "Administrator-only notifications" and then display the ones that admins can see. And when we change what institution admins can see, we don't have to change the heading esp. also since site admins can also be institution admins.

tags: added: academy
Changed in mahara:
assignee: nobody → Amelia Cordwell (amelia-stuffed)

Reviewed: https://reviews.mahara.org/4159
Committed: http://gitorious.org/mahara/mahara/commit/0a547c92beb77fede781d2fc75d844201f2e6bcf
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 0a547c92beb77fede781d2fc75d844201f2e6bcf
Author: Amelia Cordwell <email address hidden>
Date: Tue Jan 13 11:14:34 2015 +1300

Bug 1388682 Fix Alphabetize notification settiings

I fixed the bug number 1388682, which was the order of the notification
settings. The bug message asked to alphabetize the list of notification
settings, and I chose to fix it by alphabetizing the entire list instead
of spliting into sub headings.

Change-Id: Id74619db5c33638f0c29a2028eec94744dbb0b0d

Robert Lyon (robertl-9) on 2015-01-14
Changed in mahara:
status: Confirmed → Fix Committed
milestone: none → 15.04.0

Reviewed: https://reviews.mahara.org/4194
Committed: http://gitorious.org/mahara/mahara/commit/53b5080665735daac594ecaf5c99b57af2c6c4d9
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit 53b5080665735daac594ecaf5c99b57af2c6c4d9
Author: Amelia Cordwell <email address hidden>
Date: Fri Jan 16 09:33:37 2015 +1300

Behat test for bug #1388682-Notification Setting Order

Change-Id: Iceb0a5dd66b915713d8dade19463cbbc9c2632f6

tags: added: usermanualupdate
Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
tags: added: behat has-behat
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers