Remove superfluous folder in archived submissions

Bug #1388678 reported by Kristina Hoeppner on 2014-11-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Robert Lyon

Bug Description

Mahara 1.10+

When you archive submissions, the path to the actual file is like /var/lib/maharadata/110stable/submission/6/1414376651/ with "submission" being the folder for all submissions, "6" being the folder for the user and then the next subfolder being a timestamp for when the archive was created. Only then do you get to the actual file.

I think we can safely remove the timestamp folder as each submission has a serialized number at the end. Disadvantages of the timestamp folder:

1. It is not clear unless you are a dev that the number is a timestamp.
2. Even if you know it's a timestamp, you'd need to calculate first if it's the one file in that folder that you need or not.
3. It doesn't add value because the file names are unique.

Advantages of removing the folder:

1. You can see all archived files from one user in one folder in chronological order. That makes it easier to review the files quickly and find the ones you are looking for.
2. One level less of hierarchy.

Robert Lyon (robertl-9) on 2015-02-18
Changed in mahara:
assignee: nobody → Robert Lyon (robertl-9)
status: Confirmed → In Progress

Reviewed: https://reviews.mahara.org/4294
Committed: http://gitorious.org/mahara/mahara/commit/e9eb75b5c0bf98826bdd34e703512b1f56d88134
Submitter: Yuliya Bozhko (<email address hidden>)
Branch: master

commit e9eb75b5c0bf98826bdd34e703512b1f56d88134
Author: Robert Lyon <email address hidden>
Date: Thu Feb 19 11:19:25 2015 +1300

Remove superfluous folder in archived submissions (Bug #1388678)

As we add the date/time of the archive to the file name there is no
need to put it in a subdir named by date/time.

Change-Id: I8446c5f410e8502e4ab97802da0438ff428e0c32
Signed-off-by: Robert Lyon <email address hidden>

Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers