Can't report objectionable pages in responsive theme, on small screens

Bug #1387480 reported by Aaron Wells on 2014-10-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Unassigned

Bug Description

In the "default" theme, while looking at a portfolio page, if you shrink your window to cell-phone sized, the "Report objectionable material" link goes away. This means there's no way for a user to report an objectionable page.

(This is also true for the mahara.org theme)

Aaron Wells (u-aaronw) wrote :
tags: added: theming
description: updated
Aaron Wells (u-aaronw) wrote :

I tested this on my desktop computer with a small browser window, and in Android Chrome on my phone (which is a 540 x 960 display).

In portrait mode on my phone, only the feedback is visible. In landscape mode the other links become visible.

Son Nguyen (ngson2000) wrote :

These links become invisible in a small screen

See the lines 113-118 in the file htdocs/theme/default/static/style/views.css

I don' t know the reason. The designer may know better

The reason might have been to not overload the screen when viewed on a small device. We did remove some functionality for small screens and that might have been one of them.

Evonne is going to take a look at it.

Aaron Wells (u-aaronw) wrote :

That's understandable. Maybe on small screens we could hide the labels and just show the icons?

Evonne fixed it. Son, can you please put it through review on her behalf? The links are shown below each other on mobile. I would keep the text as the icons may not be clear to everyone directly.

Son Nguyen (ngson2000) wrote :
Changed in mahara:
status: Confirmed → Fix Committed
Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers