Support for mobile media-capture form tags

Bug #1385037 reported by Aaron Wells on 2014-10-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Son Nguyen

Bug Description

See http://dev.opera.com/articles/media-capture-in-mobile-browsers/

HTML5 adds "capture" and "accept" attributes to the file input tag, that you can use to "capture" media from input devices on the browser:

<input type="file" accept="image/*" capture="camera">
<input type="file" accept="video/*" capture="camcorder">
<input type="file" accept="audio/*" capture="microphone">

Android & iOS both support this to some extent, and will provide a button to open the camera or gallery app.

We should start using these when the user is detected to be on mobile. Clearly they'd belong on the Image and Video blocks. For file upload it's a little bit trickier, since we're willing to accept any file type. For Android that means that the generic file input is fine (because Android will let you access the filesystem), but for iOS we'd need to do accept=image or accept=video. Perhaps a pre-selector element, where the user indicates whether they want to upload a video or a picture?

Aaron Wells (u-aaronw) on 2014-10-24
Changed in mahara:
status: New → Confirmed
importance: Undecided → High
milestone: none → 1.11.0
tags: added: mobile usability
tags: added: snack-sized
Son Nguyen (ngson2000) on 2015-01-12
Changed in mahara:
assignee: nobody → Son Nguyen (ngson2000)
status: Confirmed → In Progress
Changed in mahara:
milestone: 15.04.0 → 15.10.0
Aaron Wells (u-aaronw) on 2015-10-23
Changed in mahara:
milestone: 15.10.0 → 16.04.0
Changed in mahara:
importance: High → Wishlist
milestone: 16.04.0 → 16.10.0
Robert Lyon (robertl-9) on 2016-10-20
Changed in mahara:
milestone: 16.10.0 → 16.10.1
Robert Lyon (robertl-9) on 2016-10-21
Changed in mahara:
milestone: 16.10.1 → 17.04.0

Reviewed: https://reviews.mahara.org/4155
Committed: https://git.mahara.org/mahara/mahara/commit/c27de8d0e5f3f396efb84f888b2cfcd1d6103b7b
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit c27de8d0e5f3f396efb84f888b2cfcd1d6103b7b
Author: Son Nguyen <email address hidden>
Date: Tue Jan 13 11:02:35 2015 +1300

Support mobile media-capture feature for Image blocks. Bug 1385037

Currently only handle the 'image/*' mediatype

behatnotneeded

Change-Id: I496ebc8a4881d37a8162293fc23d3f47635a1fee
Signed-off-by: Son Nguyen <email address hidden>

Robert Lyon (robertl-9) on 2017-03-06
Changed in mahara:
status: In Progress → Fix Committed
tags: added: nominatedfeature

It actually also works for audio and video on my Android phone.

Robert Lyon (robertl-9) on 2017-04-27
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers