Do not show "Delete" check box for notifications that can't be deleted

Bug #1382905 reported by Kristina Hoeppner on 2014-10-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Tobias Zeuch

Bug Description

Mahara 1.10

In the "Sent" notifications area (/artefact/multirecipientnotification/outbox.php) you see all the messages that you have sent. However, you cannot delete certain internal notifications, but you still see a check box next to them suggesting that you can delete them. You do receive a notification that you cannot delete a message type.

If you cannot delete a certain message, there should not be a check box.

tags: added: usability
Changed in mahara:
status: Confirmed → In Progress
assignee: nobody → Tobias Zeuch (tobias-zeuch-8)
milestone: none → 15.04.0

Reviewed: https://reviews.mahara.org/3866
Committed: http://gitorious.org/mahara/mahara/commit/f4dbb0162d217dfe731fbbbfb0f630a142fadd9d
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit f4dbb0162d217dfe731fbbbfb0f630a142fadd9d
Author: Tobias Zeuch <email address hidden>
Date: Thu Oct 23 09:06:55 2014 +0200

Don't show delete-checkbox in outbox for internal notification��s

Bug 1382905: Don't show checkbox to delete internal notifications in the outbox
because these cannot be deleted.

Change-Id: I64cc46c4deedfabc71a2687c5a1393ad86563196
Signed-off-by: Tobias Zeuch <email address hidden>

Robert Lyon (robertl-9) on 2014-11-10
Changed in mahara:
status: In Progress → Fix Committed
tags: added: usermanualupdate
Robert Lyon (robertl-9) on 2014-11-11
Changed in mahara:
status: Fix Committed → In Progress
Robert Lyon (robertl-9) wrote :

made a minor mistake in the clicking of 'delete' button js check to alert one if they've not ticked any checkbox (in outbox)

Robert Lyon (robertl-9) wrote :

also added the check to the inbox as well

Reviewed: https://reviews.mahara.org/3970
Committed: http://gitorious.org/mahara/mahara/commit/b9e0bfe454f66aad46d21ff40a9b2371c1e9a0ea
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit b9e0bfe454f66aad46d21ff40a9b2371c1e9a0ea
Author: Robert Lyon <email address hidden>
Date: Wed Nov 12 09:02:00 2014 +1300

Bug 1382905 - fix js check when outbox delete button clicked

Meant to alert if nothing checked when 'delete' button clicked but was
only working if no checkboxes were present. fixed up so now checks
that no checkbexes have been checked whether any are present or not.

also added check to the inbox

Change-Id: I27e1736ab29eabe2ccac55bd5e27d05c675cfb18
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2015-02-19
Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers