Scoial profile and Social Profiles

Bug #1381729 reported by Dirk Meyer on 2014-10-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Unassigned

Bug Description

I see two choices for social profile which could be confusing to users. I like the new social profile feature but I don't quite see what the functional difference is.

Dirk Meyer (dirkca68) wrote :
Aaron Wells (u-aaronw) wrote :

Hi Dirk,

The main functional difference between this and the old system, is that this one was meant to allow sites to support an open-ended list of new social media sites, such as Twitter, instead of having a hard-coded list of sites that inevitably become painfully obsolete.

But you're right about this interface. Users aren't going to know what we mean by "old messaging services". It's not like they've been following the evolution of Mahara and know that those are the messaging services that we used to have hard-wired in as profile fields.

And, asking users to pick "AIM screen name" from a menu and STILL have to write in the social site name, that's weird and repetitive as well.

It's a little late towards the 1.10.0 release to rewrite this interface in an intensive way right now, but I'll see if I can think of some way to smooth out these rough corners.

Cheers,
Aaron

Changed in mahara:
importance: Undecided → High
status: New → Confirmed
milestone: none → 1.10.0
tags: added: socialprofiles
Aaron Wells (u-aaronw) wrote :

It also might make sense to change the name of the "Social profiles" block to "Social media"...

Aaron Wells (u-aaronw) wrote :

I mean, change it from "Social profiles" to "Social media" in order to avoid confusion with the "Profile info" block.

Aaron Wells (u-aaronw) wrote :

Okay, here's my plan:

1. Change "social profiles" to "social media" or "social media accounts" throughout.

2. Get rid of the "Site name" field

3. Rename the "Network type" menu to "Social network"

4. Drop "website" from that menu, and replace it with an "other (specify name)" option, which will open up a text field.

5. When the user chooses "other", the value they put in the text field will be used for the network name. If they choose one of the recognized networks from the menu, that network will be used for the network name.

6. Change the labelling of the URL or username field so that it says something like "The URL of your profile page; or your username for an instant messaging account". And allow non-URL values there even if you choose "other"

That should reduce some of the confusion. For 1.11 we should make the list of networks expandable by the admin (much like iframe URLs).

Reviewed: https://reviews.mahara.org/3829
Committed: http://gitorious.org/mahara/mahara/commit/f95eac3382e7fe36946872bee5dbb8b10bbff7b5
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit f95eac3382e7fe36946872bee5dbb8b10bbff7b5
Author: Aaron Wells <email address hidden>
Date: Fri Oct 17 11:57:44 2014 +1300

UI improvements for SocialProfile artefact

Bug 1381729:

1. Renaming it on the user side to "Social media"

2. Not asking the user for the network name if they choose a known network type

3. Adding some of the current popular networks to the dropdown list

Change-Id: I7e38656cd174e6d6ccc2c5c61a5c844d207164ab

Reviewed: https://reviews.mahara.org/3844
Committed: http://gitorious.org/mahara/mahara/commit/ab3c8861db1eec58bf5589825b9874d35f96cb5b
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.10_STABLE

commit ab3c8861db1eec58bf5589825b9874d35f96cb5b
Author: Aaron Wells <email address hidden>
Date: Fri Oct 17 11:57:44 2014 +1300

UI improvements for SocialProfile artefact

Bug 1381729:

1. Renaming it on the user side to "Social media"

2. Not asking the user for the network name if they choose a known network type

3. Adding some of the current popular networks to the dropdown list

Change-Id: I7e38656cd174e6d6ccc2c5c61a5c844d207164ab

Aaron Wells (u-aaronw) on 2014-10-20
Changed in mahara:
status: Confirmed → Fix Committed
Aaron Wells (u-aaronw) wrote :

Robert was just pointing out to me that, in the end, the patch for this bug doesn't directly address the specific issue Dirk mentioned -- which is that the "profile info" block and the "social media" block do much the same thing.

I think we can consider this "fixed enough" for the 1.10.0 release though, because:

1. The name of the block is now "Social media", which is not as confusingly similar to "Profile information" as the old "Social Profile" name.

2. The "Social media" block actually has slightly different functionality than the "Profile information" block. It displays clickable buttons to get to all the users' social media accounts; while the Profile information block lists their profile details (not just social networks) in a different format.

3. The "Social media" block also has some extra controls that the "Profile information" block doesn't, to control formatting. This would make it non-trivial to merge the two blocks.

Kristina has spun off a separate bug to consider the specific issue of folding the "Social media" block into the "Profile information" block: https://bugs.launchpad.net/bugs/1383058

Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers