Default notification setting not kept from Mahara 1.9 to 1.10

Bug #1380829 reported by Kristina Hoeppner on 2014-10-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Robert Lyon

Bug Description

1.10RC1

When you upgrade a pre 1.10 site to 1.10, the default notification types are all set to "Email" even though you might have set them to something else in the previously one line setting "Default notification method" in Site options -> Email settings.

I think this needs to be fixed because site admins expect that the default notification method stays to what they have set it. They can be more granular in Mahara 1.10, but their previous default should make it over.

To test:

1. On Mahara 1.9 change the "Default notification method" to "Email digest" in Admin -> Config site -> Site options -> Email settings.
2. Create a user and check that the notification settings for all notification types are set to "Email digest".
3. Change one of the notification types to "Inbox" and one to "Email".
4. Upgrade the site and check that Admin -> Config site -> Site options -> Notification settings are all set to "Email digest".
5. Create a new user and log in as that user to check that all notification types are set to "Email digest".
6. Log in as the user created in step 2 and check that all notification types are still set to what that user had before the upgrade.

Eduardo (o-eduardo) wrote :

Kristina: The "Objectionable content in forum" type is a new notification type; Robert, Aaron and Kristina discussed that we leave that at the core default value instead of changing it to the default notification value that came across through the upgrade for the moment because it is more difficult to implement and many site admins may leave the default value on. The settings also only affects administrators and it can be changed afterwards / in the database. If needed, a patch could be made for a future release of Mahara.

Robert Lyon (robertl-9) wrote :

I've adjusted the patch so that the "Objectionable content in forum" type is set to previous default option (if exists).

So now all we need is a patch to remove the default email option from config table - I'll make a new patch for that
https://bugs.launchpad.net/mahara/+bug/1381184

Reviewed: https://reviews.mahara.org/3788
Committed: http://gitorious.org/mahara/mahara/commit/47ee961e8245158339e65c3442bbc50f3b875f82
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit 47ee961e8245158339e65c3442bbc50f3b875f82
Author: Robert Lyon <email address hidden>
Date: Mon Oct 13 08:55:51 2014 +1300

Making sure core message notifications are correct on upgrade

Bug 1380200 - make sure main two do not have 'none' option
Bug 1380829 - make sure the previous default email method is respected

On upgrade from 1.9 the default core notifications 'System message'
and 'Message from other users' can be set to 'none' - which is not
allowed.

This patch will fix that problem by making sure the default core
notifications are set to email and that any users are also updated to
beusing the newly set default method.

Also deals with setting the default email method correctly - the prev
change to notifications didn't set the default email method with the
correct currently being used method.

Change-Id: I98dcc8374876e20cb5c2952121b69dab99c7cf19
Signed-off-by: Robert Lyon <email address hidden>

Reviewed: https://reviews.mahara.org/3805
Committed: http://gitorious.org/mahara/mahara/commit/c9aefd3c1c571f698d52c9080327cc04c7743d78
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.10_STABLE

commit c9aefd3c1c571f698d52c9080327cc04c7743d78
Author: Robert Lyon <email address hidden>
Date: Mon Oct 13 08:55:51 2014 +1300

Making sure core message notifications are correct on upgrade

Bug 1380200 - make sure main two do not have 'none' option
Bug 1380829 - make sure the previous default email method is respected

On upgrade from 1.9 the default core notifications 'System message'
and 'Message from other users' can be set to 'none' - which is not
allowed.

This patch will fix that problem by making sure the default core
notifications are set to email and that any users are also updated to
beusing the newly set default method.

Also deals with setting the default email method correctly - the prev
change to notifications didn't set the default email method with the
correct currently being used method.

Change-Id: I98dcc8374876e20cb5c2952121b69dab99c7cf19
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2014-10-15
Changed in mahara:
status: Confirmed → Fix Committed
Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers