new version of jquery not rendering the inline js on pieform elements correctly

Bug #1375515 reported by Robert Lyon on 2014-09-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Robert Lyon
1.10
High
Robert Lyon
15.04
High
Unassigned

Bug Description

The way the jquery extracts the inline js from the rendered html is not working anymore after jquery update.

Need to fetch it in a better way.

To Test:

1) Create a new page
2) Add an embedded media block to it and and select/upload a video

What should happen:
- On save of block the video should load up ready to be played

What happens:
- Video doesn't load up (only video url link present)

Reviewed: https://reviews.mahara.org/3730
Committed: http://gitorious.org/mahara/mahara/commit/0d8856e37fb5ec70b05536d413b6a534912a9308
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit 0d8856e37fb5ec70b05536d413b6a534912a9308
Author: Robert Lyon <email address hidden>
Date: Tue Sep 30 13:00:09 2014 +1300

Adjusting the js extraction to work with new jQuery version

Bug 1375515

See bug report for testing instructions

Change-Id: I2eabfb64ad48945036e962695cfa632afea24152
Signed-off-by: Robert Lyon <email address hidden>

Reviewed: https://reviews.mahara.org/3777
Committed: http://gitorious.org/mahara/mahara/commit/43a7bcb46fb10e3b80c7ceb203f743cea72e27b4
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.10_STABLE

commit 43a7bcb46fb10e3b80c7ceb203f743cea72e27b4
Author: Robert Lyon <email address hidden>
Date: Tue Sep 30 13:00:09 2014 +1300

Adjusting the js extraction to work with new jQuery version

Bug 1375515

See bug report for testing instructions

Change-Id: I2eabfb64ad48945036e962695cfa632afea24152
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers