The length of a message for a new friend request should be limited

Bug #1373670 reported by Son Nguyen on 2014-09-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Low
Liam

Bug Description

Version: master (1.10), 1.9, and 1.8

We should limit the length of a new friend request message as it may cause the sending email failed.

Son Nguyen (ngson2000) on 2014-09-25
Changed in mahara:
status: New → Confirmed
Son Nguyen (ngson2000) on 2014-09-25
Changed in mahara:
importance: Undecided → High
Son Nguyen (ngson2000) on 2014-09-25
Changed in mahara:
importance: High → Low

So far it has come up once on one of our large instances and thus I wanted to class it as low only.

no longer affects: mahara/1.8
no longer affects: mahara/1.9
tags: added: bite-sized
no longer affects: mahara/1.10
no longer affects: mahara/1.9
no longer affects: mahara/15.04
no longer affects: mahara/trunk
Changed in mahara:
milestone: 15.04.0 → none

Since we limit the number of characters (probably to 255?), we should also have a brief help text below the box pointing that out.
It would be good to have a character count down so that people know how many more they can write instead of just being stopped from writing more.

tags: added: academy
Changed in mahara:
assignee: nobody → Sylvi Low (sylvilow-student)
Changed in mahara:
assignee: Sylvi Low (sylvilow-student) → nobody
Liam (celtichomeboy) on 2015-01-14
Changed in mahara:
assignee: nobody → Liam (celtichomeboy)
Doris (doristam138) on 2015-01-14
Changed in mahara:
status: Confirmed → Fix Committed
Changed in mahara:
status: Fix Committed → In Progress
milestone: none → 15.04.0
Son Nguyen (ngson2000) wrote :

Reviewed: https://reviews.mahara.org/4176
Committed: http://gitorious.org/mahara/mahara/commit/10d57e2514208324e296c8b8531949ef041f36d5
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit 10d57e2514208324e296c8b8531949ef041f36d5
Author: Doris Tam <email address hidden>
Date: Wed Jan 14 16:45:36 2015 +1300

Behat test for checking the leng of a message. Bug 1373670

This test is to test when you send a friend request with more than
255 characters it will give you a warning that you can't post
the friend request.

Change-Id: Ia82600b836f44fe73efe9a6c5bae75a2911bd190

Changed in mahara:
status: In Progress → Fix Committed
tags: added: nominatedfeature
Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
status: Fix Committed → Fix Released
tags: added: behat has-behat
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers