Errors installing/upgrading 1.10dev via CLI

Bug #1367998 reported by Aaron Wells on 2014-09-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Critical
Robert Lyon

Bug Description

When trying to do a clean install of the current 1.10dev HEAD (commit 7415cc3f159) via the command-line installer, I get a fatal error. Upgrading via the command-line upgrader also causes a fatal error. Installation & upgrading works fine through the web-based installer, only the command-line utilities are affected.

Here's the output when I try to install:

[INF] f0 (admin/cli/install.php:68) Installing Mahara
[INF] f0 (lib/mahara.php:218) Installing core
[INF] f0 (lib/upgrade.php:1304) Enabled 2 HTML filters.
[INF] f0 (lib/mahara.php:218) Installing firstcoredata
[INF] f0 (lib/mahara.php:218) Installing localpreinst
[INF] f0 (lib/mahara.php:218) Installing artefact.blog
[INF] f0 (lib/mahara.php:218) Installing toupgradecount
[WAR] f0 (lib/mahara.php:252) Attempt to assign property of non-object
Call stack (most recent first):
  * log_message("Attempt to assign property of non-object", 8, true, true, "/home/aaronw/www/mahara/htdocs/lib/mahara.php", 252) at /home/aaronw/www/mahara/htdocs/lib/errors.php:439
  * error(2, "Attempt to assign property of non-object", "/home/aaronw/www/mahara/htdocs/lib/mahara.php", 252, array(size 5)) at /home/aaronw/www/mahara/htdocs/lib/mahara.php:252
  * upgrade_mahara(array(size 67)) at /home/aaronw/www/mahara/htdocs/admin/cli/install.php:69

[WAR] f0 (lib/upgrade.php:428) First parameter must either be an object or the name of an existing class
Call stack (most recent first):
  * log_message("First parameter must either be an object or the na...", 8, true, true, "/home/aaronw/www/mahara/htdocs/lib/upgrade.php", 428) at /home/aaronw/www/mahara/htdocs/lib/errors.php:439
  * error(2, "First parameter must either be an object or the na...", "/home/aaronw/www/mahara/htdocs/lib/upgrade.php", 428, array(size 7)) at Unknown:0
  * property_exists(0"requires_config") at /home/aaronw/www/mahara/htdocs/lib/upgrade.php:428
  * upgrade_plugin(0) at /home/aaronw/www/mahara/htdocs/lib/mahara.php:253
  * upgrade_mahara(array(size 67)) at /home/aaronw/www/mahara/htdocs/admin/cli/install.php:69

[WAR] f0 (lib/upgrade.php:431) First parameter must either be an object or the name of an existing class
Call stack (most recent first):
  * log_message("First parameter must either be an object or the na...", 8, true, true, "/home/aaronw/www/mahara/htdocs/lib/upgrade.php", 431) at /home/aaronw/www/mahara/htdocs/lib/errors.php:439
  * error(2, "First parameter must either be an object or the na...", "/home/aaronw/www/mahara/htdocs/lib/upgrade.php", 431, array(size 7)) at Unknown:0
  * property_exists(0"requires_parent") at /home/aaronw/www/mahara/htdocs/lib/upgrade.php:431
  * upgrade_plugin(0) at /home/aaronw/www/mahara/htdocs/lib/mahara.php:253
  * upgrade_mahara(array(size 67)) at /home/aaronw/www/mahara/htdocs/admin/cli/install.php:69

[WAR] f0 (lib/errors.php:745) Field in where clause not in the update object
Call stack (most recent first):
  * log_message("Field in where clause not in the update object", 8, true, true) at /home/aaronw/www/mahara/htdocs/lib/errors.php:95
  * log_warn("Field in where clause not in the update object") at /home/aaronw/www/mahara/htdocs/lib/errors.php:745
  * SQLException->__construct("Field in where clause not in the update object") at /home/aaronw/www/mahara/htdocs/lib/dml.php:1191
  * update_record("_installed", object(stdClass), "name") at /home/aaronw/www/mahara/htdocs/lib/upgrade.php:440
  * upgrade_plugin(0) at /home/aaronw/www/mahara/htdocs/lib/mahara.php:253
  * upgrade_mahara(array(size 67)) at /home/aaronw/www/mahara/htdocs/admin/cli/install.php:69

[WAR] f0 (lib/dml.php:1191) Field in where clause not in the update object
Call stack (most recent first):
  * update_record("_installed", object(stdClass), "name") at /home/aaronw/www/mahara/htdocs/lib/upgrade.php:440
  * upgrade_plugin(0) at /home/aaronw/www/mahara/htdocs/lib/mahara.php:253
  * upgrade_mahara(array(size 67)) at /home/aaronw/www/mahara/htdocs/admin/cli/install.php:69

A nonrecoverable error occurred. This probably means you have encountered a bug in the system

Aaron Wells (u-aaronw) wrote :

Git bisect identifies this patch as the cause of the problem: https://reviews.mahara.org/#/c/3277/

tags: added: regression
summary: - Errors installing 1.10dev via CLI
+ Errors installing/upgrading 1.10dev via CLI
description: updated
Changed in mahara:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Robert Lyon (robertl-9)
milestone: none → 1.10.0

Reviewed: https://reviews.mahara.org/3692
Committed: http://gitorious.org/mahara/mahara/commit/5d1ea9b3b24612067b9840cbde6e696cd19a0858
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 5d1ea9b3b24612067b9840cbde6e696cd19a0858
Author: Aaron Wells <email address hidden>
Date: Thu Sep 11 14:58:37 2014 +1200

Fixing cli install / upgrade regression (Bug #1367998)

When you request that check_upgrades() checks for upgrades in all
components, the return data now includes a false component called
"settings". I've moved "disablelogin", "newinstallcount" and "toupgradecount" into that settings component.

Change-Id: I57e26e0e05848da607b8a44089c92547ebda078b

Robert Lyon (robertl-9) on 2014-09-15
Changed in mahara:
status: Confirmed → Fix Committed
Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers