extract file gives error if there is not enough space for extraction

Bug #1363753 reported by Robert Lyon on 2014-08-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Low
Robert Lyon
1.10
Low
Unassigned
15.04
Low
Robert Lyon
15.10
Low
Robert Lyon

Bug Description

If I have a user that has 5MB quota and upload a zip file that is 3MB in size - it uploads fine

But if I then click on the unzip icon for the file I get the useful message:

'Your remaining file quota is too small to unzip this file.' - however this needs to be more obvious like in a error or warn message.

But I also get:

[WAR] c0 (artefact/file/extract.php:113) Undefined variable: form
Call stack (most recent first):

    log_message("Undefined variable: form", 8, true, true, "/home/robertl/htdocs/mahara-devel/mahara/htdocs/ar...", 113) at /home/robertl/htdocs/mahara-devel/mahara/htdocs/lib/errors.php:439
    error(8, "Undefined variable: form", "/home/robertl/htdocs/mahara-devel/mahara/htdocs/ar...", 113, array(size 69)) at /home/robertl/htdocs/mahara-devel/mahara/htdocs/artefact/file/extract.php:113

I believe this is because the form isn't present when the extraction won't fit - but still something wants to interact with that form.

So things to do:

1) Make the 'Your remaining file quota is too small to unzip this file.' message more prominent - and also give some information on how to get more quota like 'contact your admin for more space and/or delete some files before proceeding' etc.

2) Stop trying to access a form that is, rightly, not there.

Robert Lyon (robertl-9) on 2014-08-31
Changed in mahara:
status: New → Confirmed
Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
milestone: 15.04.0 → 15.04.1
Mahara Bot (dev-mahara) wrote :

Patch for "15.04_STABLE" branch: https://reviews.mahara.org/5116

Reviewed: https://reviews.mahara.org/5115
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/45690928f036eb29ecab85e583b42e35ad5bbe19
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit 45690928f036eb29ecab85e583b42e35ad5bbe19
Author: Robert Lyon <email address hidden>
Date: Mon Aug 17 13:37:14 2015 +1200

Bug 1363753: tidying up file extract page

Supressing form error and styling the error message / form button

behatnotneeded

Change-Id: I4d627bcd45afc028cd0b85159f5c57e2a5037709
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/5116
Committed: https://git.nzoss.org.nz/mahara/mahara/commit/2e3eb9afc469a440198d5209cee023417ff61c46
Submitter: Robert Lyon (<email address hidden>)
Branch: 15.04_STABLE

commit 2e3eb9afc469a440198d5209cee023417ff61c46
Author: Robert Lyon <email address hidden>
Date: Mon Aug 17 13:37:14 2015 +1200

Bug 1363753: tidying up file extract page

Supressing form error and styling the error message / form button

behatnotneeded
Change-Id: I4d627bcd45afc028cd0b85159f5c57e2a5037709
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2016-11-06
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers