Uploadcsvusers broken fields - maildisabled and authinstance

Bug #1352027 reported by Nigel Cunningham on 2014-08-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Low
Robert Lyon

Bug Description

In current master at the time of writing, uploadcsvusers says in its description that the user can include the fields maildisabled and authinstance in a CSV file, but seeking to do so results in the error:

Fatal error: Class 'ArtefactTypeMaildisabled' not found

(And the same for an authinstance related class).

Robert Lyon (robertl-9) on 2014-08-04
Changed in mahara:
milestone: none → 1.10.0
assignee: nobody → Robert Lyon (robertl-9)
importance: Undecided → Low
status: New → Confirmed
Robert Lyon (robertl-9) on 2014-08-04
Changed in mahara:
status: Confirmed → Fix Committed
Robert Lyon (robertl-9) on 2014-08-04
Changed in mahara:
status: Fix Committed → In Progress
Son Nguyen (ngson2000) wrote :

Do we need backport this for previous release?

Robert Lyon (robertl-9) wrote :

We would need to check where/when the maildisabled and authinstance were added to the form and make backports accordingly

That changed in 1.10 I believe. I can't choose the authinstance as a CSV field in 1.9. Maildisabled as option has been there for a long time, but since nobody complained, I don't think we'd need to worry. I would say that most users only use the most basic fields and then use the other tick options instead of the maildisabled CSV option.

Reviewed: https://reviews.mahara.org/3564
Committed: http://gitorious.org/mahara/mahara/commit/6b4e9f6a3fe0299cd4d293ea4196fac1d3cc0899
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit 6b4e9f6a3fe0299cd4d293ea4196fac1d3cc0899
Author: Robert Lyon <email address hidden>
Date: Tue Aug 5 07:05:58 2014 +1200

Removed maildisabled and authinstnace options from list (Bug #1352027)

The way that bulk user csv upload works the authinstance is set for
all users on the csv via institution field in the upload form so we
don't need that column in the csv file.

Same with mail disabled - there is a checkbox on the form that we can
tick/untick to deal with that.

So I've got the system to not display those options on the choices list.

Change-Id: Ib2b3e2f19ee0f8aeed03c7dc04af076721ce8b41
Signed-off-by: Robert Lyon <email address hidden>

Changed in mahara:
status: In Progress → Fix Committed
Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers