can't add textbox to page in IE10

Bug #1341413 reported by Robert Lyon on 2014-07-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Son Nguyen
1.10
High
Son Nguyen
1.9
High
Robert Lyon

Bug Description

This relates to IE 10 on windows.

If I try to add a textbox to the page by clicking on the 'textbox' option at top of chooser list I get the placement dialog box and when I click 'Save' I get this error:

  The 'blocktype' parameter is not alphabetical only

If I try and do the same thing with the 'textbox' option under the 'General' section it works fine.

It looks as though the system is passing the blocktype variable as blank rather equal to 'textbox'

Same happens with the two 'image' options so it looks to be an issue with the two options at the top of the chooser list.

Son Nguyen (ngson2000) on 2014-07-14
Changed in mahara:
assignee: nobody → Son Nguyen (ngson2000)

Reviewed: https://reviews.mahara.org/3491
Committed: http://gitorious.org/mahara/mahara/commit/6ee9ea10586cd9a88655d1d31ea77e2502db338e
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 6ee9ea10586cd9a88655d1d31ea77e2502db338e
Author: Son Nguyen <email address hidden>
Date: Tue Jul 15 13:42:38 2014 +1200

Fix IE issue when adding a blocktype (Bug 1341413)

The dynamic change of an input element from type=radio to type hidden
caused its value set to "" in IE.
It would be better to just hiding it instead of changing its type.

Change-Id: Id6a86f2e9a4bba2f2988e7fcbc3fac8f3d8468a2
Signed-off-by: Son Nguyen <email address hidden>

Robert Lyon (robertl-9) on 2014-07-24
Changed in mahara:
status: Confirmed → Fix Committed

Reviewed: https://reviews.mahara.org/3558
Committed: http://gitorious.org/mahara/mahara/commit/c893823b0b94d4cbe357a8ba9e3c120b22c770df
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit c893823b0b94d4cbe357a8ba9e3c120b22c770df
Author: Robert Lyon <email address hidden>
Date: Thu Jul 31 13:25:26 2014 +1200

Fixing problem where drag and click both fire (Bug #1341413)

Change-Id: I596099e895c4199ab699dd7a2e14803822832338
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Patch for "1.9_STABLE" branch: https://reviews.mahara.org/3561

Robert Lyon (robertl-9) on 2014-07-31
Changed in mahara:
status: Fix Committed → In Progress
Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/3563

Reviewed: https://reviews.mahara.org/3563
Committed: http://gitorious.org/mahara/mahara/commit/753628206498fd5def552df20aa0bb23af740840
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit 753628206498fd5def552df20aa0bb23af740840
Author: Robert Lyon <email address hidden>
Date: Mon Aug 4 13:21:30 2014 +1200

Problem with mousedown/drag both firing (Bug #1341413)

It looks like if we have the drag code first it stops the click from
firing the addblock dialog box from also happening.

Change-Id: If261fcfb2185b647d2fab61d8f2c4f7369ff8e9d
Signed-off-by: Robert Lyon <email address hidden>

Aaron Wells (u-aaronw) on 2014-10-20
Changed in mahara:
milestone: 1.10.0 → none
Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/3560
Committed: http://gitorious.org/mahara/mahara/commit/97d916c20d4dcab3a56ce34c59f7b6f2678d5321
Submitter: Son Nguyen (<email address hidden>)
Branch: 1.9_STABLE

commit 97d916c20d4dcab3a56ce34c59f7b6f2678d5321
Author: Son Nguyen <email address hidden>
Date: Tue Jul 15 13:42:38 2014 +1200

Fix IE issue when adding a blocktype (Bug 1341413)

The dynamic change of an input element from type=radio to type hidden
caused its value set to "" in IE.
It would be better to just hiding it instead of changing its type.

Change-Id: Id6a86f2e9a4bba2f2988e7fcbc3fac8f3d8468a2
Signed-off-by: Son Nguyen <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/3561
Committed: http://gitorious.org/mahara/mahara/commit/d4cbe95c55eb10649fe241c6ad7ba026b98043df
Submitter: Son Nguyen (<email address hidden>)
Branch: 1.9_STABLE

commit d4cbe95c55eb10649fe241c6ad7ba026b98043df
Author: Robert Lyon <email address hidden>
Date: Thu Jul 31 13:25:26 2014 +1200

Fixing problem where drag and click both fire (Bug #1341413)

Change-Id: I596099e895c4199ab699dd7a2e14803822832338
Signed-off-by: Robert Lyon <email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers