Static function 'X' should not be abstract

Bug #1337547 reported by Robert Lyon on 2014-07-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Low
Aaron Wells
1.7
Low
Unassigned
1.8
Low
Unassigned
1.9
Low
Unassigned

Bug Description

I noticed these errors for mahara:

PHP Strict Standards: Static function PluginArtefact::get_artefact_types() should not be abstract in /var/www/mahara/htdocs/artefact/lib.php on line 31
PHP Strict Standards: Static function PluginArtefact::get_block_types() should not be abstract in /var/www/mahara/htdocs/artefact/lib.php on line 41
PHP Strict Standards: Static function PluginArtefact::get_plugin_name() should not be abstract in /var/www/mahara/htdocs/artefact/lib.php on line 49
PHP Strict Standards: Static function ArtefactType::get_icon() should not be abstract in /var/www/mahara/htdocs/artefact/lib.php on line 767
PHP Strict Standards: Static function ArtefactType::is_singular() should not be abstract in /var/www/mahara/htdocs/artefact/lib.php on line 784
PHP Strict Standards: Static function ArtefactType::get_links() should not be abstract in /var/www/mahara/htdocs/artefact/lib.php on line 793
PHP Strict Standards: Static function PluginBlocktype::get_title() should not be abstract in /var/www/mahara/htdocs/blocktype/lib.php on line 55
PHP Strict Standards: Static function PluginBlocktype::get_description() should not be abstract in /var/www/mahara/htdocs/blocktype/lib.php on line 65
PHP Strict Standards: Static function PluginBlocktype::get_categories() should not be abstract in /var/www/mahara/htdocs/blocktype/lib.php on line 67
PHP Strict Standards: Static function PluginBlocktype::render_instance() should not be abstract in /var/www/mahara/htdocs/blocktype/lib.php on line 82
PHP Strict Standards: Static function PluginBlocktype::artefactchooser_element() should not be abstract in /var/www/mahara/htdocs/blocktype/lib.php on line 115
PHP Strict Standards: Static function PluginExport::get_title() should not be abstract in /var/www/mahara/htdocs/export/lib.php on line 95
PHP Strict Standards: Static function PluginExport::get_description() should not be abstract in /var/www/mahara/htdocs/export/lib.php on line 100
PHP Strict Standards: Static function GroupType::allowed_join_types() should not be abstract in /var/www/mahara/htdocs/grouptype/lib.php on line 62
PHP Strict Standards: Static function GroupType::user_allowed_join_types() should not be abstract in /var/www/mahara/htdocs/grouptype/lib.php on line 64
PHP Strict Standards: Static function GroupType::get_roles() should not be abstract in /var/www/mahara/htdocs/grouptype/lib.php on line 85
PHP Strict Standards: Static function GroupType::get_view_moderating_roles() should not be abstract in /var/www/mahara/htdocs/grouptype/lib.php on line 87
PHP Strict Standards: Static function GroupType::get_view_assessing_roles() should not be abstract in /var/www/mahara/htdocs/grouptype/lib.php on line 89
PHP Strict Standards: Static function GroupType::default_artefact_rolepermissions() should not be abstract in /var/www/mahara/htdocs/grouptype/lib.php on line 95
PHP Strict Standards: Static function LeapImportArtefactPlugin::get_import_strategies_for_entry() should not be abstract in /var/www/mahara/htdocs/import/leap/lib.php on line 2056
PHP Strict Standards: Static function LeapImportArtefactPlugin::import_using_strategy() should not be abstract in /var/www/mahara/htdocs/import/leap/lib.php on line 2265
PHP Strict Standards: Static function PluginImport::validate_transported_data() should not be abstract in /var/www/mahara/htdocs/import/lib.php on line 190
PHP Strict Standards: Static function PluginInteraction::instance_config_form() should not be abstract in /var/www/mahara/htdocs/interaction/lib.php on line 28
PHP Strict Standards: Static function PluginInteraction::instance_config_save() should not be abstract in /var/www/mahara/htdocs/interaction/lib.php on line 33
PHP Strict Standards: Static function InteractionInstance::get_plugin() should not be abstract in /var/www/mahara/htdocs/interaction/lib.php on line 182
PHP Strict Standards: Declaration of ActivityTypeUsermessage::update_url() should be compatible with ActivityType::update_url() in /var/www/mahara/htdocs/lib/activity.php on line 1123
PHP Strict Standards: Static function Plugin::get_plugintype_name() should not be abstract in /var/www/mahara/htdocs/lib/mahara.php on line 1754
PHP Strict Standards: Static function PluginNotification::notify_user() should not be abstract in /var/www/mahara/htdocs/notification/lib.php on line 20
PHP Strict Standards: Static function PluginSearch::search_user() should not be abstract in /var/www/mahara/htdocs/search/lib.php on line 96
PHP Strict Standards: Static function PluginSearch::search_group() should not be abstract in /var/www/mahara/htdocs/search/lib.php on line 133
PHP Strict Standards: Static function PluginSearch::group_search_user() should not be abstract in /var/www/mahara/htdocs/search/lib.php on line 142
PHP Strict Standards: Static function PluginSearch::self_search() should not be abstract in /var/www/mahara/htdocs/search/lib.php on line 172

--------------------------------------------

By the looks of things the way we are designing our abstract functions is not quite correct. Looking at http://www.php.net/manual/en/migration52.incompatible.php

"Dropped abstract static class functions. Due to an oversight, PHP 5.0.x and 5.1.x allowed abstract static functions in classes. As of PHP 5.2.x, only interfaces can have them."

And looking at http://www.php.net/manual/en/language.oop5.late-static-bindings.php

We may need to switch to late static bindings (or something else)

Aaron Wells (u-aaronw) on 2014-07-04
Changed in mahara:
importance: High → Low
milestone: 1.10.0 → 1.8.4
milestone: 1.8.4 → 1.10.0

Reviewed: https://reviews.mahara.org/3474
Committed: http://gitorious.org/mahara/mahara/commit/7c77ed15e54b27ceeded5bc87965762e9f428e51
Submitter: Yuliya Bozhko (<email address hidden>)
Branch: master

commit 7c77ed15e54b27ceeded5bc87965762e9f428e51
Author: Aaron Wells <email address hidden>
Date: Fri Jul 4 11:56:00 2014 +1200

Remove a bunch of abstract static methods of abstract classes to satisfy E_STRICT

Bug 1337547

Change-Id: Idad2fa23d7f30300ed2d602ce2325e0560d7d831
Signed-off-by: Ghada El-Zoghbi <email address hidden>

Changed in mahara:
status: Confirmed → Fix Committed
Changed in mahara:
assignee: nobody → Aaron Wells (u-aaronw)
Mahara Bot (dev-mahara) wrote :

Patch for "1.9_STABLE" branch: https://reviews.mahara.org/3738

Mahara Bot (dev-mahara) wrote :

Patch for "1.8_STABLE" branch: https://reviews.mahara.org/3741

Reviewed: https://reviews.mahara.org/3738
Committed: http://gitorious.org/mahara/mahara/commit/f886e242ede4bfd4d731428d042a76e4dc995704
Submitter: Son Nguyen (<email address hidden>)
Branch: 1.9_STABLE

commit f886e242ede4bfd4d731428d042a76e4dc995704
Author: Aaron Wells <email address hidden>
Date: Fri Jul 4 11:56:00 2014 +1200

Remove a bunch of abstract static methods of abstract classes to satisfy E_STRICT

Bug 1337547

Change-Id: Idad2fa23d7f30300ed2d602ce2325e0560d7d831
Signed-off-by: Ghada El-Zoghbi <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/3741
Committed: http://gitorious.org/mahara/mahara/commit/2de1ddffdf1aef0d097bb5550f59e5d7b3c50c17
Submitter: Son Nguyen (<email address hidden>)
Branch: 1.8_STABLE

commit 2de1ddffdf1aef0d097bb5550f59e5d7b3c50c17
Author: Aaron Wells <email address hidden>
Date: Fri Jul 4 11:56:00 2014 +1200

Remove a bunch of abstract static methods of abstract classes to satisfy E_STRICT

Bug 1337547

Change-Id: Idad2fa23d7f30300ed2d602ce2325e0560d7d831
Signed-off-by: Ghada El-Zoghbi <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/3737
Committed: http://gitorious.org/mahara/mahara/commit/22193dacba9dac4ae111e3ad848bc1a37d12c4ad
Submitter: Son Nguyen (<email address hidden>)
Branch: 1.7_STABLE

commit 22193dacba9dac4ae111e3ad848bc1a37d12c4ad
Author: Aaron Wells <email address hidden>
Date: Fri Jul 4 11:56:00 2014 +1200

Remove a bunch of abstract static methods of abstract classes to satisfy E_STRICT

Bug 1337547

Change-Id: Idad2fa23d7f30300ed2d602ce2325e0560d7d831
Signed-off-by: Ghada El-Zoghbi <email address hidden>
Signed-off-by: Robert Lyon <email address hidden>

Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers