When placing multiple feedbacks, previous feedback text shows up in text field

Bug #1321972 reported by Aaron Wells on 2014-05-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Robert Lyon
1.7
Medium
Robert Lyon
1.8
Medium
Robert Lyon
1.9
Medium
Robert Lyon

Bug Description

As described here: https://mahara.org/interaction/forum/topic.php?id=6317

1. Go to a portfolio page that allows feedback
2. Click on the "Place feedback" button at the bottom of the page
3. Type in the text message are and submit your feedback
4. Click on the "Place feedback" button again.

Expected Result: The feedback area should be empty and ready for your second feedback

Actual Result: The text from the first feedback is present in the message area

Aaron Wells (u-aaronw) wrote :

Using git bisect, it appears that this is a regression that was caused when we upgraded TinyMCE to version 3.4.7.

It's present in Mahara versions 1.5 through 1.9.

The bug is NOT present in Mahara 1.10. Presumably it was fixed as part of our upgrade to TinyMCE 4.

Changed in mahara:
milestone: 1.8.4 → none
Aaron Wells (u-aaronw) wrote :

Regression from the patch to this bug: https://bugs.launchpad.net/mahara/+bug/869193

Robert Lyon (robertl-9) on 2014-05-22
Changed in mahara:
assignee: nobody → Robert Lyon (robertl-9)
Robert Lyon (robertl-9) wrote :

Probably do the change for master branch as well as the change deals with clearing tinymce directly rather than the textarea field.

Changed in mahara:
milestone: none → 1.10.0

Reviewed: https://reviews.mahara.org/3377
Committed: http://gitorious.org/mahara/mahara/commit/6ddbb2c1dd75ded2dc4e7868b49b9bbb58761621
Submitter: Son Nguyen (<email address hidden>)
Branch: 1.9_STABLE

commit 6ddbb2c1dd75ded2dc4e7868b49b9bbb58761621
Author: Robert Lyon <email address hidden>
Date: Thu May 22 15:47:49 2014 +1200

Clearing the tinymce editor after feedback submitted (Bug #1321972)

Instead of trying to clear the textarea of content we just clear the
active tinymce of content.

Change-Id: I59bfc9b7f8dc41e94a801ff27f5d3f92395347df
Signed-off-by: Robert Lyon <email address hidden>

Aaron Wells (u-aaronw) wrote :

The first patch fixes the problem for TinyMCE, but it breaks things for people who have TinyMCE disabled (because it makes a reference to the tinyMCE object, which will be undefined).

So I filed a follow-up patch to fix that. The other thing to keep in mind is that comments can be in the comment block or at the bottom of the page, and we need to test both of those situations, for TinyMCE enabled and disabled (which makes 4 total test scenarios)

Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/3465

Reviewed: https://reviews.mahara.org/3451
Committed: http://gitorious.org/mahara/mahara/commit/ee7c78eaca90a89ebc1f841b0352ed560a002d68
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.9_STABLE

commit ee7c78eaca90a89ebc1f841b0352ed560a002d68
Author: Aaron Wells <email address hidden>
Date: Thu Jun 19 14:35:12 2014 +1200

Clear feedback text on second comment, even if TinyMCE is disabled

Bug 1321972

Change-Id: I12e0be7b01e461fd951582be9365d30c5cfeddbf

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/3465
Committed: http://gitorious.org/mahara/mahara/commit/d2b8ae5827087a501dce8b121d7096cb0c77740f
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit d2b8ae5827087a501dce8b121d7096cb0c77740f
Author: Aaron Wells <email address hidden>
Date: Thu Jun 19 14:35:12 2014 +1200

Clear feedback text on second comment, even if TinyMCE is disabled

Bug 1321972

Change-Id: I12e0be7b01e461fd951582be9365d30c5cfeddbf

Robert Lyon (robertl-9) on 2014-06-30
Changed in mahara:
status: Confirmed → Fix Committed

Reviewed: https://reviews.mahara.org/3466
Committed: http://gitorious.org/mahara/mahara/commit/e76a56a56a14a00e69662ffb01c46b5fd8f39f46
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.8_STABLE

commit e76a56a56a14a00e69662ffb01c46b5fd8f39f46
Author: Aaron Wells <email address hidden>
Date: Thu Jun 19 14:35:12 2014 +1200

Clear feedback text on second comment, even if TinyMCE is disabled

Bug 1321972

Change-Id: I12e0be7b01e461fd951582be9365d30c5cfeddbf

Reviewed: https://reviews.mahara.org/3467
Committed: http://gitorious.org/mahara/mahara/commit/db9c621c6ea1b0c16ca2b0df9e149e5e69f13c99
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.7_STABLE

commit db9c621c6ea1b0c16ca2b0df9e149e5e69f13c99
Author: Aaron Wells <email address hidden>
Date: Thu Jun 19 14:35:12 2014 +1200

Clear feedback text on second comment, even if TinyMCE is disabled

Bug 1321972

Change-Id: I12e0be7b01e461fd951582be9365d30c5cfeddbf

Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers