Problem with pagination and plan blocks

Bug #1317295 reported by Robert Lyon on 2014-05-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Robert Lyon
1.9
High
Robert Lyon

Bug Description

User Ali Hastie reported on the forum https://mahara.org/interaction/forum/topic.php?id=6296&offset=0&limit=10#post26668

"Our students have embedded their Mahara plans within a Mahara page. When they have two pages worth of tasks within their plans you can only see the first page of tasks (displays up to ten tasks per section) for the plan and cannot access or navigate the second section of tasks. They can only view the first section of their embeded Plan tasks."

I've also tested this and it does look to be a problem that needs to be fixed

Robert Lyon (robertl-9) wrote :

Works as expected in 1.8 so looks to be only broken for 1.9 and master

Robert Lyon (robertl-9) wrote :

Git bisect tells me that the commit that broke things is: 572d93fc9bd6ff5fa0a7e23920bada5b5d20758c

and by initial looks of things I suspect the adding of the 'heading' variable in the middle of the Paginator variable list is causing some problems.

Mahara Bot (dev-mahara) wrote :

Patch for "1.9_STABLE" branch: https://reviews.mahara.org/3335

Reviewed: https://reviews.mahara.org/3335
Committed: http://gitorious.org/mahara/mahara/commit/a2efbf75b2b6e1ab3fc92e42f488b5847463bbd4
Submitter: Aaron Wells (<email address hidden>)
Branch: 1.9_STABLE

commit a2efbf75b2b6e1ab3fc92e42f488b5847463bbd4
Author: Robert Lyon <email address hidden>
Date: Thu May 8 11:17:46 2014 +1200

Plan block pagination broken (Bug #1317295)

- regression due to this commit 572d93fc9bd6ff5fa0a7e23920bada

Change-Id: Id4b48d411d264fdd116c63caa3e733e8e9ac160b
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/3334
Committed: http://gitorious.org/mahara/mahara/commit/e878e5b0b2bc2a0c2a147893ecc8d6f27157ec84
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit e878e5b0b2bc2a0c2a147893ecc8d6f27157ec84
Author: Robert Lyon <email address hidden>
Date: Thu May 8 11:17:46 2014 +1200

Plan block pagination broken (Bug #1317295)

- regression due to this commit 572d93fc9bd6ff5fa0a7e23920bada

Change-Id: Id4b48d411d264fdd116c63caa3e733e8e9ac160b
Signed-off-by: Robert Lyon <email address hidden>

Aaron Wells (u-aaronw) wrote :

Well, this is probably a good reason to put out a 1.9.1 release.

tags: added: pagination plans regression
Changed in mahara:
status: In Progress → Fix Committed

Reviewed: https://reviews.mahara.org/3340
Committed: http://gitorious.org/mahara/mahara/commit/2f466feb111c69724f42e8bad1c4d14a14c11a8a
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 2f466feb111c69724f42e8bad1c4d14a14c11a8a
Author: Aaron Wells <email address hidden>
Date: Mon May 12 11:07:41 2014 +1200

Paginator() takes 5 params now

Bug1317295

Change-Id: I6d755d62bdbf30768a16ffe17d819c7c23efd577

Reviewed: https://reviews.mahara.org/3341
Committed: http://gitorious.org/mahara/mahara/commit/2ec53db628af89da96f1bb7dec9170a09485c2c6
Submitter: Aaron Wells (<email address hidden>)
Branch: 1.9_STABLE

commit 2ec53db628af89da96f1bb7dec9170a09485c2c6
Author: Aaron Wells <email address hidden>
Date: Mon May 12 11:07:41 2014 +1200

Paginator() takes 5 params now

Bug1317295

Change-Id: I6d755d62bdbf30768a16ffe17d819c7c23efd577

Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers