marking page objectionable now allows feedback

Bug #1310861 reported by Robert Lyon on 2014-04-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Robert Lyon

Bug Description

If user A:
- creates a page
- turns off feedback/comments
- shares it with logged in users

And User B comes along and marks it as objectionable

The ability to leave comments is activated and so now user C, D, and E can all leave comments.

This is all due to the view_access table getting updated with 'allowcomments' column set to a hardcoded 1 rather than respecting the settings of the view.

I could imagine that an Admin user, who has the permissions to update a page as 'not objectionable' may also want the ability to leave a comment as well.

But I believe for all other users they should not be allowed to leave a comment.

So we either need to respect the allow comment setting for the page when saving the view_access 'objectionable' row,
 or get it so that if the only allowcomments value set to 1 is on the accesstype 'objectionable' for the page then only allow certain users (admins) to be allowed to leave a comment.

Aaron Wells (u-aaronw) wrote :

Yep, probably the reasonable thing here would be that the obectionable access row only grants comment permission to admins.

Robert Lyon (robertl-9) wrote :

Ok I've added a patch so that if the access rule that is being checked is called 'objectionable' then the allow comments option is only taken into account for admins or institutional admins.

Changed in mahara:
status: Confirmed → In Progress
assignee: nobody → Robert Lyon (robertl-9)

Reviewed: https://reviews.mahara.org/3271
Committed: http://gitorious.org/mahara/mahara/commit/ee77e0365c1991aaa236ef5d5abb554e3e36fe1b
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit ee77e0365c1991aaa236ef5d5abb554e3e36fe1b
Author: Robert Lyon <email address hidden>
Date: Wed Apr 23 08:13:27 2014 +1200

Only Admins can comment on objectionable pages when comments turned off

Bug 1310861

Currently if someone marks a page, that has comments set to off,
objectionable then eveyone that can access the page can now leave
comments.

Have adjusted it so that only admins can leave comments.

Change-Id: I82bd01814e73c39b056082965a6b483e6346a82f
Signed-off-by: Robert Lyon <email address hidden>

Changed in mahara:
status: In Progress → Fix Committed
Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers