No notifications on pages/artefacts for groups/institutions

Bug #1307247 reported by Robert Lyon on 2014-04-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Robert Lyon

Bug Description

Currently if a user leaves feedback on a group or institution page / artefact there is no notifications sent out to interested parties.

The problem exists in ActivityTypeArtefactCommentFeedback (artefact/comment/lib.php) on approx line 1205 where if there is no owner id it doesn't follow thru to the sending of notifications. This needs to be changed so that groups/institutions also get notifications.

Currently the notification is only designed to be sent to the first user in an array of users (containing only one user, the owner of page/artefact). This will need to change so that it can actually loop through users if there is more than one to be notified for groups/institutions.

The question is who are the users that need to receive the feedback notification? Is it the group/institution admins? all members? Institution staff (for institutions)? Only those users in group/institution watching the page?

I'm not sure to whom we should restrict the comment notification message - please feel free to add suggestions to this bug report.

Could there be a setting in the Group settings which the admin of the group can enable?
eg: Notifications on group pages go to > all members, admin(s), selected member(s)

Aaron Wells (u-aaronw) wrote :

The existing feature that's closest to this is the "Shared page notifications" feature for groups. That's a tickbox on the group settings page, which determines whether or not (all) group members get a notification when a page is shared with the group.

I think it would make the most sense if the config for shared page notifications, and the config for feedback notifications, were the same. So that either means:

1. We simply add a checkbox for feedback notifications, and if it's ticked, all group members get a notification.

2. OR, we make it into a multi-select that lets you choose which roles in the group get feedback notifications, and we change the shared page notifications config to be the same sort of multi-select.

As noted in the instructions for the shared page notifications, the notifications should be turned off by default, because if you have a group with a lot of users in it then this will produce a lot of notifications.

Robert Lyon (robertl-9) on 2014-05-06
Changed in mahara:
assignee: nobody → Robert Lyon (robertl-9)
Robert Lyon (robertl-9) wrote :

Have added a patch to allow for feedback on groups to send emails

Have added a feedback notify option on the group -> edit page to choose which group members get the emails

Have also adjusted the 'shared page notifications' option on the group -> edit page to choose which group members get the emails

Have also adjusted the feedback emails so that they are in the institution's lang the user belongs to if they don't have their own user lang set.

Will now get something similar for institutions working

Robert Lyon (robertl-9) on 2014-05-07
Changed in mahara:
status: Confirmed → In Progress
Mahara Bot (dev-mahara) wrote :

Patch for "master" branch: https://reviews.mahara.org/3333

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/3333
Committed: http://gitorious.org/mahara/mahara/commit/3e12f1dcfc5620889e26d1d2ffec4ce68dc55969
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit 3e12f1dcfc5620889e26d1d2ffec4ce68dc55969
Author: Robert Lyon <email address hidden>
Date: Thu May 8 10:36:45 2014 +1200

Feedback notify emails for institution pages (Bug #1307247)

For institution pages the feedback notify emails will be sent to the
institutional admins - received by institution_and_site_admins()
function (ie the site admins and institutional admins).

I didn't see any benefit of sending it to all institution members so
didn't create the ability to do that.

Change-Id: I76d48f0bc27912f017953063b39c2c47f73ae8e3
Signed-off-by: Robert Lyon <email address hidden>

Reviewed: https://reviews.mahara.org/3332
Committed: http://gitorious.org/mahara/mahara/commit/3b0382ef3d414b038cc51955faea2989c13d2f5f
Submitter: Yuliya Bozhko (<email address hidden>)
Branch: master

commit 3b0382ef3d414b038cc51955faea2989c13d2f5f
Author: Robert Lyon <email address hidden>
Date: Wed May 7 10:51:43 2014 +1200

Allowing feedback notifications on group pages (Bug #1307247)

In this patch:
- Changed the Group Edit 'General' section and added the 'Feedback
notifications' options.
- Changed the Group Edit 'General' section and altered the 'Shared
page' option from tickbox to select options.
- Changed the CommentFeedback to be able to notify multiple users in a
group
- Changed the CommentFeedback to be able to send message in the
institution lang if needed.
- Adjusted group_get_editroles_options() to allow it to return a non
associative array

Signed-off-by: Robert Lyon <email address hidden>

Change-Id: Ia2e995c51aa08610945788e55c809b3c650dcd17

Changed in mahara:
status: In Progress → Fix Committed
tags: added: nominatedfeature
Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers