custom theme goes white on save

Bug #1305275 reported by Robert Lyon on 2014-04-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Robert Lyon
1.9
High
Unassigned

Bug Description

In master:

If I save an institution with custom theme set it goes all white (#FFFFFF).

The changes to the colour select box have broken things.

Instead of opting out of using transparent one needs to opt in - and the custom theme colour choices do not have the opt out of using transparent checkbox.

It will be better to switch this around and have the selecting of using transparent (inherit existing colour) on the skins editing page to be the checkbox option.

Robert Lyon (robertl-9) on 2014-04-09
Changed in mahara:
milestone: none → 1.10.0
status: New → Confirmed
importance: Undecided → High
Robert Lyon (robertl-9) on 2014-04-09
Changed in mahara:
assignee: nobody → Robert Lyon (robertl-9)
Robert Lyon (robertl-9) on 2014-04-09
Changed in mahara:
status: Confirmed → In Progress

Reviewed: https://reviews.mahara.org/3213
Committed: http://gitorious.org/mahara/mahara/commit/f3e612a552578081375d0a22c0815936f39ca645
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit f3e612a552578081375d0a22c0815936f39ca645
Author: Robert Lyon <email address hidden>
Date: Thu Apr 10 08:13:47 2014 +1200

Colour form option not saving properly (Bug #1305275)

The 'customise' optional checkbox was breaking the saving of colours
for boxes without optional setting. This is due to the 'transparent'
being the default and the colour the optional choice.

Altered it so the colour is the default and choosing 'transparent' is
the optional choice for backwards compatibility.

Change-Id: I76e4f2f9557f3f3b8d3baf13cd35ac95d05618f2
Signed-off-by: Robert Lyon <email address hidden>

Son Nguyen (ngson2000) on 2014-04-14
Changed in mahara:
status: In Progress → Fix Committed

Reviewed: https://reviews.mahara.org/3244
Committed: http://gitorious.org/mahara/mahara/commit/3f36e7fee022597e9070fce2e82913474bc33d49
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.9_STABLE

commit 3f36e7fee022597e9070fce2e82913474bc33d49
Author: Robert Lyon <email address hidden>
Date: Thu Apr 10 08:13:47 2014 +1200

Colour form option not saving properly (Bug #1305275)

The 'customise' optional checkbox was breaking the saving of colours
for boxes without optional setting. This is due to the 'transparent'
being the default and the colour the optional choice.

Altered it so the colour is the default and choosing 'transparent' is
the optional choice for backwards compatibility.

Change-Id: I76e4f2f9557f3f3b8d3baf13cd35ac95d05618f2
Signed-off-by: Robert Lyon <email address hidden>

Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers