Allow new user default view templates to be edited

Bug #1303551 reported by Nathan Lewis on 2014-04-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Nathan Lewis

Bug Description

We want to allow admins to edit the default profile, dashboard and group 'about' pages that are generated when a new user or group is created.

The patch adds a subtab item 'Templates' under 'Configure site'. There, admins can edit the three templates. Only layout and content can be edited. Changes to these templates only affect users and groups that are created after the changes are made.

Version: master

Aaron Wells (u-aaronw) on 2014-04-07
Changed in mahara:
milestone: none → 1.10.0
importance: Undecided → Medium
status: New → Confirmed
importance: Medium → Wishlist
tags: added: nominatedfeature
Changed in mahara:
assignee: nobody → Nathan Lewis (nathan-lewis)
status: Confirmed → In Progress
Aaron Wells (u-aaronw) wrote :

I placed some comments onto the gerrit review.

I think, interface-wise, it would be better if we just displayed these pages under the Administration -> Pages tab (admin/site/views.php). Much like when you're examining your own pages, or the pages for a group, we'd show them at the top of the list, without the "delete" icon next to them. And change their titles as displayed on that page, to "Default new user homepage", "Default new user dashboard", and "Default new group homepage".

Aaron Wells (u-aaronw) wrote :

It's also worth noting, the first two things that users are going to ask for once they see this new functionality:

1. The ability for institutions to customize these templates

2. The ability to edit the pages of already-created users and groups.

I'm okay with taking an incremental approach, and adding these things later. :) Plus, there are some difficult questions involved in item #2 above, at least if you care about not wiping out the user's own customizations to their homepage.

Hi Aaron.

I'd initially thought of the idea of putting them in with Admin->Pages and
had it half working like that, but then changed my mind. I can't remember
why. I'll have another look and figure out why, since that reason might not
be valid any more. Oh, I remember. I tried modifying the function that gets
the pages, to return the templates as well, but it was going to be messy.
Maybe I could make two calls to get all the pages and templates. I'll have
a look.

I had briefly thought of institution templates but didn't bother thinking
it through. Is it important? I believe the institution's theme will be
applied since you can't set theme on the template. Will that not be
sufficient?

The patch that follows this is supposed to be the ability to lock the user
profiles and a "reset" button to reset them to the template. I talked to
Yuliya and we agreed that it should only be profiles that should be
lockable/resetable, not dashboard and group about. The idea is that
profiles can (possibly) be viewed site wide or even by external users, so
we want them consistent, whereas dashboard is personal. I'm not sure what
to say about group about. I also thought about what to do with customized
profiles when the locking is activated - maybe change the profile to a
portfolio page. But that has it's own problems - what if it's already
locked and the admin makes a small change - everyone ends up with another
copy of the profile in their portfolio. I've just had another idea - what
if we could redirect everyone to the template if it is locked, then we
don't need to delete or modify the user profile pages - they can edit them
and open them, but it says "This profile page is being overridden by the
template".

Any comments on any of the above?

Nathan

On 10 April 2014 15:24, Aaron Wells <email address hidden> wrote:

> It's also worth noting, the first two things that users are going to ask
> for once they see this new functionality:
>
> 1. The ability for institutions to customize these templates
>
> 2. The ability to edit the pages of already-created users and groups.
>
> I'm okay with taking an incremental approach, and adding these things
> later. :) Plus, there are some difficult questions involved in item #2
> above, at least if you care about not wiping out the user's own
> customizations to their homepage.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1303551
>
> Title:
> Allow new user default view templates to be edited
>
> Status in Mahara ePortfolio:
> In Progress
>
> Bug description:
> We want to allow admins to edit the default profile, dashboard and
> group 'about' pages that are generated when a new user or group is
> created.
>
> The patch adds a subtab item 'Templates' under 'Configure site'.
> There, admins can edit the three templates. Only layout and content
> can be edited. Changes to these templates only affect users and groups
> that are created after the changes are made.
>
> Version: master
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/mahara/+bug/1303551/+subscriptions
>

Aaron Wells (u-aaronw) wrote :

Hi Nathan,

1. Probably making two calls, to get the predefined templates, and then to get the normal site-level pages, is the way to go.

2. Yeah, probably there'll be someplace where they have a killer use-case based all around institutions being able to customize new user dashboards and profiles (groups are trickier, because groups don't really have an institution...). Like, perhaps there's a school where groups are central to how they do things, so they want students to have a "My Groups" block on the dashboard. But then another school thinks their students aren't very technical, so they want the dashboard to have fewer blocks. Etc. But like I said, we can handle that in another bug.

3. In 1.9 institutions can customize the "Static pages", which includes the welcome text shown at the top of the dashboard, so that at least gives them another way to customize the page anyway.

4. So this ability to "lock" user profiles, this would mean that the user can't edit their profile page? I suspect there'll be admins who'd want to lock the dashboard page as well. In a school setting they'd probably prefer to lock the dashboard (in order to control the student's main interface with the site) and unlock the profile page (so students can express themselves through their profile). I can't see much need for locking group homepages.

4.1. Also, this should probably be a per-institution setting, which can be overridden by a site-level setting. Keeping in mind that a user can belong to more than one institution! So it'd be something like, if any of the user's institutions has locked the page, you lock it.

4.2. And perhaps staff and admins should have the ability to unlock their own pages? (And/or unlock these pages for individual users?) Via a checkbox on their account settings page.

5. Yeah, I'm not sure what to do about the conflict between customized pages & locked-forced-update pages. I suppose there are three possibilities:

5.1: Convert the student's old profile into a normal Portfolio page. Like you said, this could clutter their Portfolio (though they could always delete them). You could limit this by only making a copy if the student customized their profile, but it may be hard to detect if a student has customized their profile.

5.2: Just wipe out the customized profile page.

5.3: Attempt to merge the customized page and the new template.

I guess the best way to do things would be that the admin "locks" the profile and/or dashboard before any users are added to the Institution, so that they never notice the change. But you do need to make it possible to switch an Institution from a "locked" state to an "unlocked" state. In which case... maybe have a confirmation page where you ask the admin, hey, do you want to just wipe out people's customized pages, or should they get a backup?

Pushing template updates also gets tricky if you have institution templates. :) On the other hand, relatively few users belong to multiple institutions, so I wouldn't worry about it too much.

Cheers,
Aaron

Reviewed: https://reviews.mahara.org/3205
Committed: http://gitorious.org/mahara/mahara/commit/d1765fef8691c0d9ab0779c9040132e5449695a4
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit d1765fef8691c0d9ab0779c9040132e5449695a4
Author: Nathan Lewis <email address hidden>
Date: Mon Apr 7 15:06:45 2014 +1200

Allow new user default view templates to be edited (Bug #1303551)

- Adds template views to top of Pages list under Configure site menu
- Profile, dashboard and group homepage templates can be edited.
- Only layout and content can be edited.
- Templates are only applied to users and groups created after changes are made.

Change-Id: I35967950a37887b31595a4afbc19300dd070949f
Signed-off-by: Nathan Lewis <email address hidden>

Changed in mahara:
status: In Progress → Fix Committed
Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers