Sanity check for plugin installation

Bug #1298855 reported by Tobias Zeuch on 2014-03-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Robert Lyon

Bug Description

I propose a sanity check for plugins before they are installed automatically with the system installation. Right now, when the installation of a single plugin fails, all plugins that would have been installed thereafter are skipped as well.
The problem occurred with a plugin that depends on a artefact type that comes with another plugins, so with the sanity check the dependent plugin can check, if the artefact type was already installed.
A sanity check could also be used to check the installation of PHP-extensions or external programs.
The sanity check should also be called before a plugin is offered for installation after the core installation.

Aaron Wells (u-aaronw) wrote :

I filed a separate bug for the related idea of a versions & dependencies check, because I still think that could be useful too: https://bugs.launchpad.net/mahara/+bug/1299908

Changed in mahara:
importance: Undecided → Wishlist
status: New → Confirmed
tags: added: api install plugins snack-sized upgrade

Reviewed: https://reviews.mahara.org/3156
Committed: http://gitorious.org/mahara/mahara/commit/75a9f3d0d48ee38810485ab94e7ec7e5469cf62f
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 75a9f3d0d48ee38810485ab94e7ec7e5469cf62f
Author: Tobias Zeuch <email address hidden>
Date: Mon Mar 31 17:26:30 2014 +0200

Bug 1298855: new method Plugin::sanity_check() that is called upon install or
update of the plugin. Caught exception InstallException results in the
error-message being presented to the user and the plugin not being installed
while the installation process continues

Change-Id: Iba04bbfebe7b192409cd2e943d7449f0ec258eca
Signed-off-by: Tobias Zeuch <email address hidden>

Robert Lyon (robertl-9) on 2014-04-06
Changed in mahara:
milestone: none → 1.10.0
assignee: nobody → Robert Lyon (robertl-9)
status: Confirmed → Fix Committed

Reviewed: https://reviews.mahara.org/3204
Committed: http://gitorious.org/mahara/mahara/commit/a78e99e70a4f304f27398df83bc7b624e4c425b5
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit a78e99e70a4f304f27398df83bc7b624e4c425b5
Author: Robert Lyon <email address hidden>
Date: Mon Apr 7 12:34:29 2014 +1200

Fixing problem for upgrading core (Bug #1298855)

Caused creation of fail symbol to show on successful upgrade.

Change-Id: I0d6e3cfb84d857cf9b4588242b010a3eefc530eb
Signed-off-by: Robert Lyon <email address hidden>

tags: added: nominatedfeature
Aaron Wells (u-aaronw) on 2014-10-21
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers