external feed rss not updating

Bug #1284878 reported by Robert Lyon
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Fix Released
High
Robert Lyon
1.7
Fix Released
High
Robert Lyon
1.8
Fix Released
High
Robert Lyon

Bug Description

The change 70f75a2d75af47aa11aa93ee5b587d41caf957e9 sets the lastupdate column in blocktype_externalfeed_data to null via this bit of code db_format_timestamp('0')

Which in itself is fine - but the refresh_feeds() call can't handle the null value so doesn't update the feed.

If one edits a feed the lastupdate field is populated with a date and can be processed again.

As the problem has been around since 1.7 I propose to fix it by letting refresh_feeds() handle the null as well - this way existing bad data will get cleaned up.

Revision history for this message
Robert Lyon (robertl-9) wrote :

To test:
1) Create a site with pre 1.7 mahara and add some pages with rss feed blocks on them
2) View db: select id, lastupdate from blocktype_externalfeed_data; should return lastupdate column with dates in it
3) Upgrade site to 1.7 or later
4) View db: select id, lastupdate from blocktype_externalfeed_data; shows lastupdate column as all null

Revision history for this message
Mahara Bot (dev-mahara) wrote : A patch has been submitted for review

Patch for "master" branch: https://reviews.mahara.org/3041

Aaron Wells (u-aaronw)
Changed in mahara:
status: Confirmed → Fix Committed
Robert Lyon (robertl-9)
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers