Suspended user login attempts show up in "Online Users" list

Bug #1284869 reported by Aaron Wells on 2014-02-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Aaron Wells
1.8
Medium
Aaron Wells

Bug Description

When a suspended user attempts to log in, if they enter their password correctly they see a message telling them they've been suspended, and the suspension reason the admin entered. They're also immediately logged out.

The bug is that this unsuccessful login attempt updates their "lastlogin" and "lastaccess" database fields. And that makes them show up in the "Online Users" sideblock, even though they shouldn't show up because they're not able to get in and do anything in the site.

Aaron Wells (u-aaronw) on 2014-02-25
Changed in mahara:
milestone: none → 1.8.2
status: New → Confirmed
Aaron Wells (u-aaronw) wrote :

Note: This patch is already in place on mahara.org

Aaron Wells (u-aaronw) on 2014-03-07
description: updated

Reviewed: https://reviews.mahara.org/3045
Committed: http://gitorious.org/mahara/mahara/commit/e700f2df82b3eb0e34ee4c7987bfdc371803eebf
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit e700f2df82b3eb0e34ee4c7987bfdc371803eebf
Author: Aaron Wells <email address hidden>
Date: Wed Feb 26 12:53:07 2014 +1300

Don't update "lastaccess" and "lastlogin" when login fails due to being suspended

Bug 1284869

Change-Id: Ic7c116dd09b501c35df61f735063f4c187016585

Aaron Wells (u-aaronw) on 2014-03-11
no longer affects: mahara/1.7
no longer affects: mahara/1.6

Reviewed: https://reviews.mahara.org/3150
Committed: http://gitorious.org/mahara/mahara/commit/3040d81e52b95cea773ba044ae44dc2e0842838c
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.8_STABLE

commit 3040d81e52b95cea773ba044ae44dc2e0842838c
Author: Aaron Wells <email address hidden>
Date: Wed Feb 26 12:53:07 2014 +1300

Don't update "lastaccess" and "lastlogin" when login fails due to being suspended

Bug 1284869

Change-Id: Ic7c116dd09b501c35df61f735063f4c187016585

Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
no longer affects: mahara/1.9
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers