institution general pages not set as site default on upgrade

Bug #1283839 reported by Robert Lyon on 2014-02-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Robert Lyon

Bug Description

When upgrading from older version the institution general pages do not initially get set as using site default (when you add a new institution it does).

Robert Lyon (robertl-9) on 2014-02-23
Changed in mahara:
importance: Undecided → Medium
assignee: nobody → Robert Lyon (robertl-9)
milestone: none → 1.9.0
status: New → In Progress
status: In Progress → Confirmed
Robert Lyon (robertl-9) on 2014-02-23
Changed in mahara:
status: Confirmed → In Progress
Jono Mingard (mingard) wrote :

What exactly is the issue here? If I create a 1.8 site, add an institution, upgrade to 1.9 and edit that institution's general pages they seem to be the same as the site default ones anyway (and no errors occur) ...

Robert Lyon (robertl-9) wrote :

The issue is when you first go to edit the general pages they should be set to 'use site default' ie the checkbox should be ticked and the tinymce should be greyed out.

it should be the same as when you add an institution after upgrade.

Reviewed: https://reviews.mahara.org/3034
Committed: http://gitorious.org/mahara/mahara/commit/84981bcf5cdd022e687622ead35b3e1f13e6ad0c
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 84981bcf5cdd022e687622ead35b3e1f13e6ad0c
Author: Robert Lyon <email address hidden>
Date: Mon Feb 24 11:45:30 2014 +1300

Setting general pages to site default on upgrade (Bug #1283839)

Change-Id: I6fa2bd76a6862c39378c9399c17d50279e92d421
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2014-02-24
Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers