Let users from controlled-registration institutions delete their accounts

Bug #1281364 reported by shanen on 2014-02-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Aaron Wells

Bug Description

Mahara 1.8

A colleague would like to see an option for users who have not self-registers to delete their account. "What about the ability to unregister? Seems to me that that is a pretty basic requirement. It confirms in each student's mind that anything put up is owned by the student, and that any decisions on whether to participate or opt-out are entirely under each student's control."

This feature exists for users who have self registered, is it something that could be done for other users? pros/cons?

Thanks,
Shane.

Aaron Wells (u-aaronw) on 2014-02-26
Changed in mahara:
status: New → Triaged
importance: Undecided → Wishlist
summary: - Let users de-register from Mahara
+ Let (non-self-registered) users de-register from Mahara

I've always seen the feature the following way:

1. When you can self-register, you pretty much are your own person and thus decide over your own account.
2. If you are registered by an external authentication method or even just added by CSV file and the admin does not allow self-registration, your institution would like you to keep an ePortfolio and thus you shouldn't delete it or maybe even delete it accidentally, e.g. when it may be used for assessment purposes.

How do you see it from an institutional point of view?

Hi Kristina,
I would agree with your points of view.
I guess this is an issue for people who wish to retain control over their content/identity to the point of having the power to remove it from a system. Though I can't imagine they would have this ability with any other institutional UC system. There must be a policy on this at UC, I'll follow up with that first.
Thanks!

Aaron Wells (u-aaronw) on 2014-03-09
summary: - Let (non-self-registered) users de-register from Mahara
+ Let users from controlled-registration institutions delete their
+ accounts
Aaron Wells (u-aaronw) wrote :

The way the code is currently written is that a user is given the option to delete themselves unless they belong to an institution that has "Registration allowed" disabled. So it doesn't actually matter what your auth method is, or whether you self-registered. It's just whether your institution allows self-registration.

Since the implementation was quite simple, I've put together a quick patch that adds a config.php option to always allow users to delete their accounts: https://reviews.mahara.org/3089

Thanks Aaron,
This will be very useful for those providers that want to enable this option.
Kind regards,
Shane.

Aaron Wells (u-aaronw) on 2014-03-10
Changed in mahara:
status: Triaged → Fix Committed
status: Fix Committed → Confirmed

Reviewed: https://reviews.mahara.org/3089
Committed: http://gitorious.org/mahara/mahara/commit/42bf48091e22b896f8c398a7961af5e55e73b0fc
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 42bf48091e22b896f8c398a7961af5e55e73b0fc
Author: Aaron Wells <email address hidden>
Date: Mon Mar 10 11:02:31 2014 +1300

Config option to always allow users to delete their accounts

Bug 1281364

Change-Id: Icd51e651b9caed278fd1074a15e177996a9fffac

Aaron Wells (u-aaronw) on 2014-03-11
Changed in mahara:
status: Confirmed → Fix Committed
milestone: none → 1.9.0
assignee: nobody → Aaron Wells (u-aaronw)
Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
tags: added: nominatedfeature
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers