Add the option Require 'Confirm registrations' in site administration

Bug #1280882 reported by Son Nguyen on 2014-02-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Son Nguyen

Bug Description

This option enables site admins not to allow institution admins to tick off "Confirm registrations".

Institution admins can decide to turn off "Confirm registrations" which is not good as site admins may wish to decide that this option should never be turned off to create a more secure site so that only really approved users can get an account created no matter to which institution they belong.

We should create a site admin setting:

Require "Confirm registrations" which the site admin can tick and then institution admins cannot untick that anymore. If the site admin doesn't tick this box, institution admins can decide whether to require confirmation or not.

Changed in mahara:
status: New → Confirmed
assignee: nobody → Son Nguyen (ngson2000)
Son Nguyen (ngson2000) on 2014-02-16
Changed in mahara:
status: Confirmed → In Progress

Reviewed: https://reviews.mahara.org/3014
Committed: http://gitorious.org/mahara/mahara/commit/fe14bc4dc0664e3fc10580786aeb458ea7d5cd8e
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit fe14bc4dc0664e3fc10580786aeb458ea7d5cd8e
Author: Son Nguyen <email address hidden>
Date: Mon Feb 17 14:54:40 2014 +1300

Add the option Require 'Confirm registrations' (Bug 1280882)

If set, this option will overwrite the institution 'Confirm
registration' setting

Change-Id: I28cf952c3629005d86c31354e39581e74324a26f
Signed-off-by: Son Nguyen <email address hidden>

Changed in mahara:
milestone: none → 1.10.0
status: In Progress → Fix Committed
tags: added: nominatedfeature
Son Nguyen (ngson2000) on 2014-04-30
no longer affects: mahara/1.8

Reviewed: https://reviews.mahara.org/3304
Committed: http://gitorious.org/mahara/mahara/commit/9b9e7e7ec3f78c551ef3b291d29e8586e7ec32b2
Submitter: Son Nguyen (<email address hidden>)
Branch: 1.8_STABLE

commit 9b9e7e7ec3f78c551ef3b291d29e8586e7ec32b2
Author: Son Nguyen <email address hidden>
Date: Mon Feb 17 14:54:40 2014 +1300

Add the option Require 'Confirm registrations' (Bug 1280882)

If set, this option will overwrite the institution 'Confirm
registration' setting

Change-Id: I28cf952c3629005d86c31354e39581e74324a26f
Signed-off-by: Son Nguyen <email address hidden>

Aaron Wells (u-aaronw) wrote :

This was actually released as part of 1.9.0 (it was merged back in Feb when the master branch was still 1.9).

And it shouldn't be backported to 1.8 because it's a new feature. We should revert that backport patch.

Changed in mahara:
milestone: 1.10.0 → 1.9.0
status: Fix Committed → Fix Released

Reviewed: https://reviews.mahara.org/3305
Committed: http://gitorious.org/mahara/mahara/commit/c5b9234b9ba021a55518017b8abb7b57f921d6a0
Submitter: Aaron Wells (<email address hidden>)
Branch: 1.8_STABLE

commit c5b9234b9ba021a55518017b8abb7b57f921d6a0
Author: Aaron Wells <email address hidden>
Date: Fri May 2 12:29:55 2014 +1200

Revert "Add the option Require 'Confirm registrations' (Bug 1280882)"

This reverts commit 9b9e7e7ec3f78c551ef3b291d29e8586e7ec32b2.

New feature, shouldn't have been backported to a stable branch.

Change-Id: I7192922375dad1d7d425277f31ad4e9959c1c437

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/3430
Committed: http://gitorious.org/mahara/mahara/commit/d4263e47f383147c729b538fd93bb0cdd8e9ddbb
Submitter: Aaron Wells (<email address hidden>)
Branch: 1.9_STABLE

commit d4263e47f383147c729b538fd93bb0cdd8e9ddbb
Author: Aaron Wells <email address hidden>
Date: Tue Jun 10 17:46:54 2014 +1200

Revert "Move the setting for "Confirm registration" into institution settings"

This reverts commit a1854f018e7f3b75bbaa2dcaeaad24a38fcd3594.

Bug 1280882: It shouldn't be backported to 1.9_STABLE because it's not a bug fix, and it changes the user interface.

Change-Id: Ib3da16f75f863734e7876c0ffdf3f6e9099c65b9

Aaron Wells (u-aaronw) wrote :

Whoops, I put the wrong bug number in that commit message. It was meant to be Bug 1317265.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers