Empty, focusable <a> tags when no staff or admins shown in institution list

Bug #1278668 reported by Jono Mingard on 2014-02-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Low
Jono Mingard

Bug Description

In the list of institutions (Admin -> Institutions), "No Institution" does not display a number of staff or administrators, so those cells appear blank. However, they contain an empty <a> element which can be focused using the keyboard and gives an error if pressed.
The page needs to be changed so that the column is genuinely blank if the number of staff/admin users in an institution is not set.

Affects latest master

Jono Mingard (mingard) wrote :

(Noticed first by Evonne)

tags: added: accessibility
Jono Mingard (mingard) on 2014-02-11
Changed in mahara:
importance: Undecided → Low
Jono Mingard (mingard) on 2014-02-26
Changed in mahara:
assignee: nobody → Jono Mingard (mingard)
status: Confirmed → In Progress

Reviewed: https://reviews.mahara.org/3046
Committed: http://gitorious.org/mahara/mahara/commit/7216ff49629dccd49a9d3b4e9d16a51cfa1213cd
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit 7216ff49629dccd49a9d3b4e9d16a51cfa1213cd
Author: Jono Mingard <email address hidden>
Date: Wed Feb 26 13:00:56 2014 +1300

Remove empty links in institutions list (Bug #1278668)

Also removed link to institution page for "No institution" (ie. the institution
title is no longer a link) since it can never have institution staff
or admins.

Also fixed up the max users count to not display count = 0

Change-Id: I667ef41431f59b5036ed82d277b683a161bc6045
Signed-off-by: Jono Mingard <email address hidden>

Son Nguyen (ngson2000) on 2014-03-12
Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2014-05-19
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints