Two error messages when uploading files without accepting upload agreement

Bug #1278667 reported by Jono Mingard on 2014-02-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Jono Mingard
1.8
Medium
Robert Lyon

Bug Description

When uploading files via drag and drop, if the upload agreement is enabled and not checked, the error message "You must agree to the copyright notice." appears. However, on the current master it appears twice.
Note this behaviour may have been introduced by the patch for Bug #1262483

Jono Mingard (mingard) wrote :

(Noticed first by Evonne)

Jono Mingard (mingard) on 2014-02-12
summary: - Two error messages when uploading files without accepting upload
- agreement
+ File dropzone gives incorrect error messages
summary: - File dropzone gives incorrect error messages
+ Two error messages when uploading files without accepting upload
+ agreement
Jono Mingard (mingard) on 2014-02-12
Changed in mahara:
assignee: nobody → Jono Mingard (mingard)
status: Confirmed → In Progress

Reviewed: https://reviews.mahara.org/2999
Committed: http://gitorious.org/mahara/mahara/commit/06c09001db21cc982dd569d7a3c5513ceaad4311
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 06c09001db21cc982dd569d7a3c5513ceaad4311
Author: Jono Mingard <email address hidden>
Date: Wed Feb 12 14:50:59 2014 +1300

Stop client side validation when uploading files via dropzone (Bug #1278667)

Since there's no way to stop the files being uploaded when they're added to
the dropzone there's no point doing client-side validation as it'll be
duplicated on the server

Change-Id: I7891b333eb3f74cc1c05cd521674ff9d0f53b60b
Signed-off-by: Jono Mingard <email address hidden>

Robert Lyon (robertl-9) on 2014-02-12
Changed in mahara:
status: In Progress → Fix Committed
milestone: none → 1.9.0
importance: Undecided → Medium

Reviewed: https://reviews.mahara.org/3002
Committed: http://gitorious.org/mahara/mahara/commit/7c1c120feb3be8821d96b0367181c090a34ca065
Submitter: Robert Lyon (<email address hidden>)
Branch: 1.8_STABLE

commit 7c1c120feb3be8821d96b0367181c090a34ca065
Author: Jono Mingard <email address hidden>
Date: Wed Feb 12 14:50:59 2014 +1300

Stop client side validation when uploading files via dropzone (Bug #1278667)

Since there's no way to stop the files being uploaded when they're added to
the dropzone there's no point doing client-side validation as it'll be
duplicated on the server

Change-Id: I7891b333eb3f74cc1c05cd521674ff9d0f53b60b
Signed-off-by: Jono Mingard <email address hidden>

Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers