Navigation and tabs are broken in IE11

Bug #1275995 reported by Jono Mingard on 2014-02-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Evonne Cheung

Bug Description

Regression introduced by https://reviews.mahara.org/#/c/2834/

List items in main navigation, sub navigation and in page tabs all now display as blocks in IE11, meaning they appear stacked on top of each other rather than side by side.
Previously the page was given the ie7 class in IE11, which forced these to use display: inline rather than display: table-cell. Although Firefox and Chrome are fine, Internet Explorer seems to display the list items as blocks unless their display style is set to inline (inline-block and table-cell are both ignored).

Should be tested to see if this also any other versions of IE.

Affects latest master

Jono Mingard (mingard) wrote :

It may be as simple as adding <meta http-equiv="X-UA-Compatible" content="IE=edge" /> (IE may be using an old rendering engine for some reason - in fact, if that is the cause it may be possible to track down what's doing that and remove it)

Aaron Wells (u-aaronw) on 2014-02-25
Changed in mahara:
status: New → Confirmed
Aaron Wells (u-aaronw) on 2014-02-27
Changed in mahara:
assignee: nobody → Evonne Cheung (evonne)
Jono Mingard (mingard) wrote :

This is caused by IE's default Compatibility View settings (for whatever reason any intranet site renders in IE7 mode by default). It can be fixed by simply going to Compatibility View settings and unticking "Display intranet sites in compatibility view".
The meta tag also works though and it would probably be good to include it for people who don't know about the setting or require compatibility view for other internal sites ...

Robert Lyon (robertl-9) on 2014-03-25
Changed in mahara:
status: Confirmed → Fix Committed
Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers