[Ongoing] All images need descriptive alt text

Bug #1271772 reported by Jono Mingard on 2014-01-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Jono Mingard

Bug Description

Parent bug: Please make a new bug report for each section that is fixed which references this bug in the description, and add a comment here with the new bug number.

To be accessible to screen readers, all images and image-like elements need an alt attribute specified. This should either describe what the image looks like or what it does (if it's an image link or button).

The following areas are affected
- Close button in homeinfo (introductory section on Dashboard) [now in Bug #1278198]
- Edit and delete buttons in Journal (turns out they need 'alt' rather than 'value') [now in Bug #1276397]
- Delete buttons in Notes [now in Bug #1276397]
- Skin previews [now in Bug #1278202]

Also, the top "Settings" image should have null alt text set since the text "Settings" is immediately beside it (at the moment, screen readers read out "Settings Settings") [now in Bug #1282872]

Affects latest master

(WCAG Level A)

Jono Mingard (mingard) on 2014-01-24
description: updated

Jono, since a lot of different areas of Mahara are affected, it might be better to spin of individual bugs for each big item unless you want to fix them all at once.

Changed in mahara:
status: New → Confirmed
Jono Mingard (mingard) on 2014-01-26
tags: added: wcag
Jono Mingard (mingard) wrote :

Spun off Bug #1273448 for Resume Attachments icons. My plan is to spin off bugs gradually (when I want to fix each thing) rather than making heaps all at once, although if you'd prefer another approach Kristina be sure to let me know.

description: updated

As discussed on IRC, it would be great if you labeled the high level bugs briefly so that it's clear that you are going to spin off indivdiual ones when you get to them instead of creating a whole series of bugs. That way we know that this is on your radar, Jono. :-)

Works for me also that you update both the child and parent bugs with the respective bug numbers so we always know which ones relates to what. Creating a blueprint for each relationship may be a bit of an overkill. Besides then we couldn't link the accessibility blueprint anymore which is important.

Jono Mingard (mingard) on 2014-01-27
description: updated
Changed in mahara:
status: Confirmed → In Progress
assignee: nobody → Jono Mingard (mingard)
summary: - All images need descriptive alt text
+ [Ongoing] All images need descriptive alt text
Jono Mingard (mingard) on 2014-02-05
description: updated
Jono Mingard (mingard) wrote :

Spun off Bug #1276397 for edit and delete buttons

description: updated
Jono Mingard (mingard) on 2014-02-06
description: updated
Jono Mingard (mingard) on 2014-02-06
description: updated
description: updated
Jono Mingard (mingard) on 2014-02-09
description: updated
Jono Mingard (mingard) on 2014-02-10
description: updated
Jono Mingard (mingard) on 2014-02-21
description: updated
Aaron Wells (u-aaronw) on 2014-04-14
Changed in mahara:
milestone: 1.9.0 → 1.10.0
Aaron Wells (u-aaronw) on 2014-09-09
Changed in mahara:
milestone: 1.10.0 → 1.11.0
Robert Lyon (robertl-9) on 2015-04-17
Changed in mahara:
milestone: 15.04.0 → 15.04.1
Aaron Wells (u-aaronw) wrote :

I think we've gotten most of these. Let's open a separate bug for individual images or sections of the code with images in them, for any remaining ones.

Changed in mahara:
status: In Progress → Fix Released
milestone: 15.04.1 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints