no message when incorrect username entered

Bug #1270846 reported by Leo Xiong on 2014-01-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Aaron Wells
1.9
High
Aaron Wells

Bug Description

When a nonexistent username is entered in the login form, the 'loginfailed' string is not displayed; unlike the expected behaviour when an existent username with an incorrect password is entered.

Current version: Mahara version 1.9.0dev (2014010800)

Aaron Wells (u-aaronw) wrote :

This is a regression in 1.9dev. Steps to replicate:

1. Go to the Mahara front page while logged out
2. In the login form, enter a non-existent username, and a password.
3. Click "Login" (or hit enter)

Expected result: You should see this warning message, and the same username and password (or at least a sufficient number of asterisks) should be present in the login form: "You have not provided the correct credentials to log in. Please check your username and password are correct."

Actual result: The page blinks as if reloading, and then displays the home page without any warning message, and the login form completely empty.

tags: added: regression
Aaron Wells (u-aaronw) wrote :

Using git bisect, I traced it to the JSDetector: https://reviews.mahara.org/#/c/1800/

Given how many problems the JSDetector has caused, and that we're not even using it currently, I'm in favor of just reverting it. I'll file a bug for that.

tags: added: jsdetector
Aaron Wells (u-aaronw) wrote :

Reviewed: https://reviews.mahara.org/2944
Committed: http://gitorious.org/mahara/mahara/commit/1a5d395cdb87a7e2ae14f251a562315f5ace87c6
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 1a5d395cdb87a7e2ae14f251a562315f5ace87c6
Author: Aaron Wells <email address hidden>
Date: Tue Jan 21 14:39:42 2014 +1300

Revert "Add class JavascriptDetector for checking if javascript is enabled"

This reverts commit 1cdc0486e956fbc4e2e1a10f50818156aece16ce.

The JSDetector class has caused three regressions so far (Bug 1270846,
Bug 1261610, and Bug 1268788). Since it's been buggy and it's not
actively in use anywhere in the site, I think we should revert it.

Change-Id: If32d5adf8733ce3f455aab09a5d138c7707ae95d

Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers