"shared with me" pagination fails with IE 9

Bug #1270752 reported by finnnns on 2014-01-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Aaron Wells
1.8
High
Aaron Wells
1.9
High
Aaron Wells

Bug Description

In Mahara 1.8.1 when there's more than 10 views in the "shared with me" tab the pagination does not work.

This affects

Windows Internet Explorer 9, Version 9.0.8112.16421
Update version: 9.0.23

Windows 7 Entreprise

which is a default software at our UAS, unfortunately.

Other browser do not fail.

Server operating system Linux
Database MySQL

Tags: ie Edit Tag help
finnnns (boesl2) wrote :
finnnns (boesl2) wrote :

I forgot: independently of compatibility mode or no compatibility mode.

Aaron Wells (u-aaronw) wrote :

Note: According to the Mahara 1.8 README it supports IE 8, 9, and 10.

Changed in mahara:
milestone: none → 1.8.2
status: New → Triaged
importance: Undecided → High
tags: added: ie
Aaron Wells (u-aaronw) wrote :

I don't have a copy of IE9 at hand, but I was able to replicate this problem using IE10 with the Developer Tool browser emulation settings set to simulate IE9.

To replicate:

1. Launch IE10. Press F12 to open the developer tools. Press Ctrl-8 to see the emulation settings. Set Document mode to "9".
2. Log in to Mahara as User 1.
3. Create 14 pages. Share them User 2.
4. Log in to Mahara as User 2.
5. Go to "Portfolio -> Shared with me"
6. Go to the bottom of the page where the paginator links are. You'll see text that reads "<< First", "<- Previous", "1", "2", "Next ->", "Last >>", with the latter three being links.
7. Try to click on "2", "Next ->" or "Last >>".

Expected result: You should see the rest of the results after the first 10.

Actual result: Nothing happens. The mouse pointer turns into a finger indicating there is a link present, but clicking does nothing as if there were no link.

Aaron Wells (u-aaronw) wrote :

As mentioned by the bug reporter, this problem doesn't occur in other browsers. I specifically found it to work successfully in Firefox on Ubuntu, and in IE10 on Win7pro.

I also tested it in earlier versions of IE and found that it doesn't work in any emulation mode earlier than IE10. Though since Mahara 1.8 only officially supports IE8 and later, we only need to focus on fixing it for IE8 & IE9.

Aaron Wells (u-aaronw) wrote :

It would appear this is a regression caused by the patch https://reviews.mahara.org/#/c/1832/ in Mahara 1.8.0.

It changes the paginator from using the surrounding <div>'s innerHTML, to using the table's innerHTML. But my research indicates that in IE9 and earlier, the innerHTML of a <table> is read-only: http://msdn.microsoft.com/en-us/library/ms533897%28VS.85%29.aspx

When I revert that commit in 1.8_STABLE, I am unable to replicate the original bug it was meant to fix (Bug 993676). So, it would appear that we've either fixed the problem somewhere else in the code, or the behavior in Chromium that was causing the issue has been fixed on their side. Either way, I'm going to suggest reverting the patch.

Reviewed: https://reviews.mahara.org/2942
Committed: http://gitorious.org/mahara/mahara/commit/bec3fd2d5db5acaa6f63bc7c577321280251b25b
Submitter: Aaron Wells (<email address hidden>)
Branch: 1.8_STABLE

commit bec3fd2d5db5acaa6f63bc7c577321280251b25b
Author: Aaron Wells <email address hidden>
Date: Tue Jan 21 14:16:33 2014 +1300

Revert "fix the writing Div's innerHTML Bug #993676"

This reverts commit 40fc4950131439b20f900d939856bc4abca018c3.

Bug 1270752: This patch broke the paginator for IE9 and earlier,
because the innerHTML of a table is read-only in those versions.
Additionally, testing in IE9, 10, FF, and Chromium, with this
patch reverted, I was unable to replicate the bug that it was
meant to fix, so it appears this patch is no longer needed.

Change-Id: I231bb536ff9e288bbe81f37f48041c2942556098

Reviewed: https://reviews.mahara.org/2962
Committed: http://gitorious.org/mahara/mahara/commit/bc9ef02da82dfbedaf40185db5e8af73243b61a8
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit bc9ef02da82dfbedaf40185db5e8af73243b61a8
Author: Aaron Wells <email address hidden>
Date: Tue Jan 21 14:16:33 2014 +1300

Revert "fix the writing Div's innerHTML Bug #993676"

This reverts commit 40fc4950131439b20f900d939856bc4abca018c3.

Bug 1270752: This patch broke the paginator for IE9 and earlier,
because the innerHTML of a table is read-only in those versions.
Additionally, testing in IE9, 10, FF, and Chromium, with this
patch reverted, I was unable to replicate the bug that it was
meant to fix, so it appears this patch is no longer needed.

Change-Id: I231bb536ff9e288bbe81f37f48041c2942556098

Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers