Page shared to group: notification to page owner

Bug #1267861 reported by Ruslan Kabalin on 2014-01-10
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mahara
Medium
Aaron Wells

Bug Description

When the page owner shares page with the group, and the group has a setting to notify members when new page is shared with the group, the page owner receives notification as well. This is not correct, the page owner should be excluded from notification list if s/he is a member of the group s/he shares the page with.

Aaron Wells (u-aaronw) wrote :

I don't know, in a way the message is kind of a feature, not a bug. It lets you know that all the members of the group received a notification.

Tony Butler (tonyjbutler) wrote :

Hi Aaron,

Certainly that's one way of looking at it, but I think it would be better to simply display a message at the top of the page to inform the user that the other group members had been sent a notification. I think sending a notification to the owner of the page being shared could potentially be quite confusing - it just seems wrong to notify a user that they now have access to a page they already had access to.

I've submitted a patch for review at https://reviews.mahara.org/#/c/2934/ to exclude the owner from the notification.

Cheers,
Tony

Changed in mahara:
status: New → Opinion
Aaron Wells (u-aaronw) wrote :

Thanks for the patch, Tony. Before we merge it in, I'd like to discuss the issue just a little bit more.

1. Are end users complaining about these messages?

2. Is the problem that they're confused by the message, like not sure whether they still own the page or thinking it's someone else's page that was shared?

3. Or is the problem just that they receive too many notifications, and this is one more that they'd rather not get?

If the problem is that they're confused by the message, could we solve it just by re-wording the message? Currently it reads:

 Subject: New page access
 You have been added to the access list for the page "<page title>" by <page owner>

I can see that this is kind of confusing, because it's a generic message about page access and doesn't say anything about the group. Perhaps it would be better if it was like this:

 Subject: Page shared with group
 All members of the group "<group name>" have been granted access to the page "<page title>" by <page owner>

I'd be interested in responses to Aaron's questions as well.

In a way I think it is good that the author of the page does get an email notification because then they know that the other group members also received the notification. We've had it a few times that users then came to us and said they actually didn't want to share the page with the entire group and thus caught themselves giving long-term access to others accidentally.

I'd prefer Aaron's rewording though as it makes it clearer why you got a notification.

Tony Butler (tonyjbutler) wrote :

It seems to be a combination of both of those things. I think users are generally quite happy to receive notifications as long as they're relevant and useful (and not confusing), and rewording the notification as suggested would certainly help to improve that.

However, I still think it would be more appropriate to reword the message that appears on save, to include more detail about what has been shared and with whom. Currently it just reads: "Access rules were updated for 1 page(s)". Ideally this is the point at which the user who is actually editing the view access should be given this additional information.

Aaron Wells (u-aaronw) wrote :

After talking it over with some other people I've come around to Tony's way of thinking on this issue. It is redundant that, when a user clicks the "save" button on the "edit access" screen, they receive a notification telling themselves that they know have access to their own page.

So, I'm going to go ahead and merge this.

Reviewed: https://reviews.mahara.org/2934
Committed: http://gitorious.org/mahara/mahara/commit/dc4d83f67d3356e330a422b9e494ac5c2f1b0bcd
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit dc4d83f67d3356e330a422b9e494ac5c2f1b0bcd
Author: Tony Butler <email address hidden>
Date: Fri Jan 10 16:25:22 2014 +0000

Exclude owner from 'New page access' notifications for group members (Bug #1267861)

Change-Id: Ieb3f2d18befa2881d55aba1b8ff436eba1522c1c
Signed-off-by: Tony Butler <email address hidden>

Aaron Wells (u-aaronw) on 2014-02-27
Changed in mahara:
milestone: none → 1.9.0
importance: Undecided → Medium
status: Opinion → Fix Committed
assignee: nobody → Aaron Wells (u-aaronw)
tags: added: nominatedfeature usermanualupdate
Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released

Reviewed: https://reviews.mahara.org/3278
Committed: http://gitorious.org/mahara/mahara/commit/e0de62d4ffa7b20747e8c0785b51c0f637ae99cb
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit e0de62d4ffa7b20747e8c0785b51c0f637ae99cb
Author: Kristina D.C. Hoeppner <email address hidden>
Date: Wed Apr 23 16:06:14 2014 +1200

Add info about shared page notification & author (Bug #1311454)

Since the owner of a page who shares it with the
group does not receive notifications anymore as
per Bug #1267861, the lang string for the help
text needed updating.

Change-Id: Ie5abcdae9b839fb4919f14f1fa5c6b33dfd271c7
Signed-off-by: Kristina D.C. Hoeppner <email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers