Edit button table headers need hidden description

Bug #1265096 reported by Jono Mingard on 2013-12-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Wishlist
Jono Mingard

Bug Description

In tables with edit/delete buttons on the right (eg. in /admin/site/licenses.php and /artefact/plans/plan.php) the column header above these buttons is blank. This is annoying for screen reader users who rely on column headers to find out information about the table.
Hidden text such as "Edit buttons" or "Edit/delete" should be added to these headers.

Affects latest master

Hi Jono,

Can you please check with Julius what heading is typically used for columns such as these? If there is a standard way of describing such columns, we should be using it. :-)

Thanks
Kristina

Changed in mahara:
status: New → Confirmed
status: Confirmed → Triaged
Jono Mingard (mingard) wrote :

Julius thinks the best title for the column is simply "Edit" since "Delete" is still considered an editing command. It's something to try out rather than a standard though.

Jono Mingard (mingard) on 2014-01-27
Changed in mahara:
status: Triaged → In Progress
assignee: nobody → Jono Mingard (mingard)

Reviewed: https://reviews.mahara.org/2967
Committed: http://gitorious.org/mahara/mahara/commit/9bcbd5fdf52a937fd632b38e20ce1b104d767ab2
Submitter: Son Nguyen (<email address hidden>)
Branch: master

commit 9bcbd5fdf52a937fd632b38e20ce1b104d767ab2
Author: Jono Mingard <email address hidden>
Date: Tue Jan 28 12:47:00 2014 +1300

Added hidden column header for edit buttons (Bug #1265096)

Modified file browser, Resume, Notes, Forums, Administer groups,
Administer institutions and Allowed iframe sources

Change-Id: Idd3f7df6569c19cc1805de2871a8c8fe1e3c31c6
Signed-off-by: Jono Mingard <email address hidden>

Son Nguyen (ngson2000) on 2014-02-02
Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2014-05-19
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints