"Completed" column for tasks is unclear for screen reader users

Bug #1265086 reported by Jono Mingard on 2013-12-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Jono Mingard

Bug Description

When editing a plan in /artefact/plans/plan.php the "Completed" column currently has no text if the task is incomplete or a tick if the task is complete. However, this is not obvious to people using screen readers since the tick icon has null alt text.
To make this more accessible, hidden "Incomplete" or "No" text should be present in the column if the task is incomplete, and the tick icon used when the task is complete should have descriptive alt text.

Affects latest master (using Orca 3.10.1)

(WCAG Level A)

Hidden "Overdue" / "Completed" as alt text for the image would be better than "yes" or "no" imho because it's more descriptive esp. when you have a long list and don't want to go back to the top of the table to read the column label. I would go for "Overdue" instead of "Incomplete" because when the deadline hasn't passed yet / the completion date been reached, there is no icon in the table cell. You only see an icon when you marked the task as completed (green checkmark) or when it's overdue (red warning sign).

Jono Mingard (mingard) on 2014-01-06
Changed in mahara:
status: New → In Progress
assignee: nobody → Jono Mingard (mingard)
Jono Mingard (mingard) on 2014-01-08
Changed in mahara:
milestone: none → 1.9.0
Steven (stevens-q) wrote :

It is confirmed that there is now alt text for the check mark icon located in the completed column of tasks on the plans task page

Catalyst QA Approved ✔

Reviewed: https://reviews.mahara.org/2859
Committed: http://gitorious.org/mahara/mahara/commit/e85b481df536af2e2f265bd02ac902faf8bf7325
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit e85b481df536af2e2f265bd02ac902faf8bf7325
Author: Jono Mingard <email address hidden>
Date: Fri Jan 3 13:41:11 2014 +1300

Added alt text to task completion status icons (Bug #1265086)

In /artefact/plans/plan.php and "Plans" blocktype: Added "Completed" alt text
to tick image, "Overdue" alt text to warning image and hidden "Incomplete"
text for tasks which are not completed or overdue.

Change-Id: I261fb764715446efe39545c489f15791807e7d4c
Signed-off-by: Jono Mingard <email address hidden>

Jono Mingard (mingard) on 2014-01-22
Changed in mahara:
status: In Progress → Fix Committed
Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints