JSDetector adds output to command-line scripts

Bug #1261610 reported by Aaron Wells on 2013-12-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Unassigned

Bug Description

In Mahara 1.9dev, every time I run the command-line installer, I see this at the start of the output:

    <form name="jsdetector_form" id="jsdetector_form" method="post">
        <input name="javascriptenabled" type="hidden" value="true" />
        <script type="text/javascript">
            document.jsdetector_form.submit();
        </script>
    </form>[INF] d4 (admin/cli/install.php:68) Installing Mahara

I suspect this is from the JSDetector class that we added. We should disable that, because it's not needed when you're running at the command-line.

Reviewed: https://reviews.mahara.org/2928
Committed: http://gitorious.org/mahara/mahara/commit/8986b3313319c126a67e4f951cbe5b5a92e97c0d
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 8986b3313319c126a67e4f951cbe5b5a92e97c0d
Author: Aaron Wells <email address hidden>
Date: Wed Jan 15 12:31:22 2014 +1300

Don't run the JSDetector for CLI scripts.

Bug 1261610

Change-Id: I9f28525571da10ccf62b75f0c2134db28bf51073

Aaron Wells (u-aaronw) on 2014-01-15
Changed in mahara:
status: Confirmed → Fix Committed

Reviewed: https://reviews.mahara.org/2944
Committed: http://gitorious.org/mahara/mahara/commit/1a5d395cdb87a7e2ae14f251a562315f5ace87c6
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 1a5d395cdb87a7e2ae14f251a562315f5ace87c6
Author: Aaron Wells <email address hidden>
Date: Tue Jan 21 14:39:42 2014 +1300

Revert "Add class JavascriptDetector for checking if javascript is enabled"

This reverts commit 1cdc0486e956fbc4e2e1a10f50818156aece16ce.

The JSDetector class has caused three regressions so far (Bug 1270846,
Bug 1261610, and Bug 1268788). Since it's been buggy and it's not
actively in use anywhere in the site, I think we should revert it.

Change-Id: If32d5adf8733ce3f455aab09a5d138c7707ae95d

Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers