Datepicker buttons lack alt text

Bug #1259685 reported by Jono Mingard on 2013-12-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
Medium
Jono Mingard

Bug Description

Currently the DHTML date picker widget (for example the date field on /artefact/plans/edit/task.php) is not easy to navigate using a screen reader.
- it opens below all other elements and does not have focus set to it - this is confusing for screen reader users since activating the button appears to do nothing
- it has null alt-text, resulting in screen readers finding a variety of unrelated bits of text to read out as the title

Eventually the date picker should be made accessible by having focus locked to it while it is open (using ARIA) but for now it would be fine to disable it (somehow) for screen reader users since it's possible to enter the date in the right format by hand.

Affects latest master (using Orca 3.4.2)

(WCAG Level A)

Jono Mingard (mingard) on 2013-12-10
description: updated
Jono Mingard (mingard) on 2013-12-12
Changed in mahara:
importance: Undecided → Medium
Jono Mingard (mingard) on 2013-12-19
tags: added: meal-sized

There is also a date picker on the Edit access page /view/access.php. If you don't wnat to implement ARIA then there should be some help information on what the correct date format is like under "Advanced options".

Robert Lyon (robertl-9) wrote :

This roadmap for the jQuery UI datepicker is interesting so I'll a link to it here
http://wiki.jqueryui.com/w/page/12137778/Datepicker

It sounds like they are trying to get some usability issues sorted out.

If we can get Datepicker and timepicker plugin (possible option)
http://trentrichardson.com/examples/timepicker/

going with keyboard accessibility that would be most useful.

Question is should we wait until others have sorted this issue - or should we take a look at sorting this ourselves?

As I understand it, the current date/time picker is not keyboard accessible, so something will need to be done.

Jono Mingard (mingard) wrote :

IMHO we should wait and see how the jQuery version evolves (at least for now). Once the format description is linked with ARIA (Bug #1259388) the ability to manually enter a date/time in the correct format should constitute an "accessible alternate version" - at least for WCAG AA.

Definitely something we should look into in the future, but for now it's probably more of a nice-to-have than a necessity.

Aaron Wells (u-aaronw) wrote :

Jono posted this patch related to this bug: https://reviews.mahara.org/#/c/2873/

Jono Mingard (mingard) on 2014-01-08
Changed in mahara:
assignee: nobody → Jono Mingard (mingard)
status: New → In Progress
Jono Mingard (mingard) on 2014-01-08
summary: - Datepicker is not keyboard-accessible
+ Datepicker is not accessible to screen readers

The datepicker buttons now have alt text but the widget itself is still not accessible - I've created Bug #1267239 for the latter issue.

Changed in mahara:
status: In Progress → Fix Committed
Jono Mingard (mingard) on 2014-01-08
Changed in mahara:
milestone: none → 1.9.0
Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
Aaron Wells (u-aaronw) wrote :

Relabelling this bug to reflect the patch that was committed for it, so that it doesn't look like a simple duplicate of Bug 1267239

summary: - Datepicker is not accessible to screen readers
+ Datepicker buttons lack alt text
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints