Use of tabindex is confusing for screen readers

Bug #1259359 reported by Jono Mingard on 2013-12-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Jono Mingard

Bug Description

Mahara (latest master) uses the tabindex attribute on various forms and buttons, overriding the standard tab order. For screen reader users this is a dealbreaker in many areas, since the elements appear out-of-order when tabbing through the page.

Tab indexing is used in the following areas (and potentially others)
- The site search box
- Individual search forms (eg. in Find Groups)
- Key buttons such as "Create Page", "Edit" (in Resume -> Cover Letter), etc
- Key forms such as "Edit Title and Description" for pages

As an example, in "Contact Information" (Content -> Resume) the input fields are given a tab index but the email address radio buttons + links are not. This means that to a screen reader user, most of the form including its submit button appear to be situated above the site logo (since they're first in the tab order) while the options for email address are in their correct position much further down the page.

Since Mahara's pages are generally structured quite logically, getting rid of all tabindex attributes would vastly improve accessibility. Perhaps a key element (like the first form field) could still be focused by default for people who don't use a screen reader but want to use the keyboard?

Affects latest master (using Orca 3.4.2)

(WCAG Level A)

Jono Mingard (mingard) on 2013-12-10
tags: added: accessibility
Jono Mingard (mingard) on 2013-12-10
description: updated
Jono Mingard (mingard) on 2013-12-11
Changed in mahara:
importance: Undecided → Critical
importance: Critical → High
Changed in mahara:
status: New → Confirmed
Jono Mingard (mingard) on 2013-12-19
Changed in mahara:
status: Confirmed → In Progress
assignee: nobody → Jono Mingard (mingard)
Jono Mingard (mingard) on 2013-12-20
Changed in mahara:
status: In Progress → Fix Committed
Changed in mahara:
milestone: none → 1.9.0
Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints