public group forum info do not show up in elasticsearch

Bug #1257953 reported by Robert Lyon on 2013-12-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mahara
High
Robert Lyon
1.8
High
Son Nguyen
1.9
High
Robert Lyon

Bug Description

Currently in mahara if one creates a group and marks it as a public group and adds entries to the forum these entries can only be found in a search by members of the group.

They should be able to be found by anyone that is allowed to view the group's forum.

To test:
- Have elasticsearch turned on
- Create a group and tick the 'Publicly viewable group'
- Add some topics / replies in the forum section
- Search for * and you should see your topics / replies in the search results

Log in as another user (not a member of the group)
- You can navigate the the group eg interaction/forum/index.php?group=[id of group] and see the forum
- Search for * and you do not see the topics / replies in the search results

Also there is a problem with elasticsearch where you need to be logged in to use it which shouldn't be the case for finding info on public forums

Robert Lyon (robertl-9) wrote :

Have added a patch dealing with the indexing of public forums / forum posts
https://reviews.mahara.org/#/c/2768/

Still need to sort out making elasticsearch available for use to non logged in members so that the public can actually search the public forums

Robert Lyon (robertl-9) wrote :

Have added patch to allow the elasticsearch search form to be made public
https://reviews.mahara.org/#/c/2769/

Changed in mahara:
status: Confirmed → In Progress
assignee: nobody → Robert Lyon (robertl-9)
Aaron Wells (u-aaronw) wrote :

To provide some context, these are issues that were found while getting ready to deploy elasticsearch to mahara.org itself.

Actually, whether or not to be able to perform search while you're not logged in, should probably be a config setting. For most sites that represent educational institutions, it would probably be preferred that you can't search unless you can log in.

But for sites like mahara.org, which are about members of the public sharing with other members of the public, it's essential.

Aaron Wells (u-aaronw) wrote :

There's also the related question of whether logged-out users should be able to search only forums, or whether they should also be able to search user accounts and pages. On mahara.org, searching forums is the primary use-case. But, if a person has gone to the trouble of marking a page "Public", then perhaps they would also welcome making it searchable.

If a site doesn't allow its content to be public, it doesn't allow public pages or public groups. I don't think we would need a config setting whether public content can be searched by the public or not because you can always use Google et al. and search for the content and most likely come up with something.

If a school doesn't want it's content be found, it won't allow public pages / groups etc.

As for what should be searchable, I think when anything is marked public, you should be able to search on it because search engines can do so as well. Thus, it should not only be forums, forum posts, but also public pages that the public can search / discover.

Steven (stevens-q) wrote :

=== Prerequisites ===
Testing to be done on the following site:
 a. http://mahara-org-mahara.designmoodle.brumbies.wgtn.cat-it.co.nz/

=== How to test ===
1. log in as a site admin
2. turn on elastic search. setting can be found here [ Configure site => Search settings ]
3. Create a group and tick the 'Publicly viewable group'
4. Add some topics / replies in the forum section
5. Search for *
6. Confirm that you see your topics / replies in the search results

=== Test Results ===

6. Confirmed that you see your topics / replies in the search results ✔

Catalyst QA Approved ✔

Reviewed: https://reviews.mahara.org/2777
Committed: http://gitorious.org/mahara/mahara/commit/e8f57ea67d8716957074a752b720bca641d2fd7c
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit e8f57ea67d8716957074a752b720bca641d2fd7c
Author: Robert Lyon <email address hidden>
Date: Mon Dec 9 14:58:06 2013 +1300

Allowing for users to not show up in public search (bug 1257953)

Thinking of privacy issues here - when should the users showup on
search results.

This patch allows users to show up based on the access of their
profile page (accesstypes: public, loggedin, friends) and whether
'Show users in public search' is set or not.

Normally all profile pages are accessible by logged in users - but
this can be altered if 'Logged-in profile access' is unchecked and
users remove the access off their profile page.

Change-Id: I4daa8cb2812bddb231ba489dfeefb4843b653d40
Signed-off-by: Robert Lyon <email address hidden>

Aaron Wells (u-aaronw) wrote :

Leaving the status for this as "In Progress" because there are two patches for this bug, and one of them ( https://reviews.mahara.org/#/c/2768/ ) has not yet been merged.

Changed in mahara:
status: In Progress → Fix Committed
status: Fix Committed → In Progress
Aaron Wells (u-aaronw) wrote :

Patch https://reviews.mahara.org/2777 in particular should be backported to 1.8 because it's a privacy issue.

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/2768
Committed: http://gitorious.org/mahara/mahara/commit/8a81e0210e64d2a47515935734324919cb2af318
Submitter: Aaron Wells (<email address hidden>)
Branch: master

commit 8a81e0210e64d2a47515935734324919cb2af318
Author: Robert Lyon <email address hidden>
Date: Thu Dec 5 13:38:24 2013 +1300

Altered how public forums are indexed in elasticsearch (bug 1257953)

Elasticsearch will now index forums / forum posts as access[general] = public
rather than access[general] = none if the forum is part of a public
group.

Change-Id: I9c269fd290c52053c4ebae9f077556524b908bc5
Signed-off-by: Robert Lyon <email address hidden>

Son: The backporting to 1.8 should not be too difficult because Robert already has the patches working for mahara.org. So hopefully, all goes well.

Son Nguyen (ngson2000) wrote :

Reviewed: https://reviews.mahara.org/2969
Committed: http://gitorious.org/mahara/mahara/commit/96df0b3941ef4f1a22efde76c4da3861a08c1fa1
Submitter: Son Nguyen (<email address hidden>)
Branch: 1.8_STABLE

commit 96df0b3941ef4f1a22efde76c4da3861a08c1fa1
Author: Robert Lyon <email address hidden>
Date: Mon Dec 9 14:58:06 2013 +1300

Allowing for users to not show up in public search (bug 1257953)

Thinking of privacy issues here - when should the users showup on
search results.

This patch allows users to show up based on the access of their
profile page (accesstypes: public, loggedin, friends) and whether
'Show users in public search' is set or not.

Normally all profile pages are accessible by logged in users - but
this can be altered if 'Logged-in profile access' is unchecked and
users remove the access off their profile page.

Conflicts:

 htdocs/admin/site/options.php
 htdocs/search/elasticsearch/lib.php

Change-Id: I4daa8cb2812bddb231ba489dfeefb4843b653d40
Signed-off-by: Robert Lyon <email address hidden>

Reviewed: https://reviews.mahara.org/2970
Committed: http://gitorious.org/mahara/mahara/commit/0f99222de21770316fc7fd2587dc777c27712844
Submitter: Son Nguyen (<email address hidden>)
Branch: 1.8_STABLE

commit 0f99222de21770316fc7fd2587dc777c27712844
Author: Robert Lyon <email address hidden>
Date: Thu Dec 5 13:38:24 2013 +1300

Altered how public forums are indexed in elasticsearch (bug 1257953)

Elasticsearch will now index forums / forum posts as access[general] = public
rather than access[general] = none if the forum is part of a public
group.

Change-Id: I9c269fd290c52053c4ebae9f077556524b908bc5
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/2769
Committed: http://gitorious.org/mahara/mahara/commit/ef4f1af8d9fe024f89e7d499b395dfa0df560f34
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit ef4f1af8d9fe024f89e7d499b395dfa0df560f34
Author: Robert Lyon <email address hidden>
Date: Thu Dec 5 14:12:24 2013 +1300

Allowing searchbox for elasticsearch to be public (bug 1257953)

- TO DO: will need to make sure that the results returned by public
search are allowed to be seen by the public

Change-Id: I1787bd1ba0f26d5f7ea86d5d7f1562987f98381c
Signed-off-by: Robert Lyon <email address hidden>

Mahara Bot (dev-mahara) wrote :

Reviewed: https://reviews.mahara.org/2776
Committed: http://gitorious.org/mahara/mahara/commit/33f6ad05b2a647fadc80c1e0e3ae443c3fd8c496
Submitter: Robert Lyon (<email address hidden>)
Branch: master

commit 33f6ad05b2a647fadc80c1e0e3ae443c3fd8c496
Author: Robert Lyon <email address hidden>
Date: Mon Dec 9 13:59:18 2013 +1300

Hide non-public groups from public search (bug 1257953)

Change-Id: I283f921d677605409d19b2490c6f2b9b79a28529
Signed-off-by: Robert Lyon <email address hidden>

Robert Lyon (robertl-9) on 2014-04-22
Changed in mahara:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers